mailview is not correctly reloaded from mailViews.dat

RESOLVED DUPLICATE of bug 183158

Status

SeaMonkey
MailNews: Message Display
RESOLVED DUPLICATE of bug 183158
15 years ago
14 years ago

People

(Reporter: David Edmondson, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4b) Gecko/20030507
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4b) Gecko/20030507

Mail views which are created are not correctly reloaded when Mozilla
exits and restarts.


Reproducible: Always

Steps to Reproduce:
Create a new mail view called 'interesting'.  The settings are:
Match any of the following:
status isn't read
label is important
label is to do
label is later.

The view works well.  Quit Mozilla and then restart.  The view has been
corrupted and now reads:
Match any of the following:
status isn't replied
label is important
label is to do
label is later.

(change of 'read' to 'replied').  The contents of mailViews.dat appear correct:
(only this entry is shown)

name="interesting"
enabled="no"
type="1"
condition="OR (status,isn't,read) OR (label,is,1) OR (label,is,4) OR (label,is,5)"

Actual Results:  
See 'steps to reproduce'.


Expected Results:  
The mail view should have been correctly reloaded.

Comment 1

15 years ago
David, can you reproduce this problem using another Mozilla user profile?
(Reporter)

Comment 2

15 years ago
(re: profiles).
Yes.  Another profile shows the same problem.

I created a new profile 'test' upon starting Mozilla, started the mailer
component, exited the account wizard.  Following the originally described
steps, I then created a mail view called 'interesting' with the original
parameters.

Exiting the mail view creation tool and re-entering (in 'edit' mode)
indicated that the filter was correctly created.  The mailViews.dat file
had the correct contents (as documented above).

Exiting Mozilla and restarting with the 'test' profile, starting the mailer,
exiting the account wizard and then examining the 'interesting' view shows
that it is corrupted in the way originally described ('status isn't replied'
rather than 'status isn't read').

Comment 3

15 years ago
Confirmed using FizzillaMach/2003-05-07-14-1.4b.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

15 years ago
However, it WorksForMe using FizzillaMach/2003-05-16-08-trunk. David, please
retest using a current nightly build.
(Reporter)

Comment 5

15 years ago
Using
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4b) Gecko/20030516
(which seems to be the current nightly build) the problem does not occur.

Looking through the CVS logs, the bug was fixed as part of bug 183158.


*** This bug has been marked as a duplicate of 183158 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.