Last Comment Bug 205817 - Pages with flash animations not loading
: Pages with flash animations not loading
Status: VERIFIED FIXED
: regression, smoketest
Product: Core
Classification: Components
Component: Plug-ins (show other bugs)
: Trunk
: All All
: -- blocker (vote)
: ---
Assigned To: Peter Lubczynski
: bmartin
:
Mentors:
http://www.davetitus.com
: 205841 (view as bug list)
Depends on:
Blocks: 130265
  Show dependency treegraph
 
Reported: 2003-05-15 09:22 PDT by Tracy Walker [:tracy]
Modified: 2003-05-15 18:05 PDT (History)
9 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
stack leading up to StopAll() (2.89 KB, text/plain)
2003-05-15 12:09 PDT, Peter Lubczynski
no flags Details
Proposed fix, untested. Don't stop loads for non-document URI's (1.66 KB, patch)
2003-05-15 12:24 PDT, Johnny Stenback (:jst, jst@mozilla.com)
peterlubczynski-bugs: review+
jst: superreview+
asa: approval1.4+
Details | Diff | Splinter Review

Description Tracy Walker [:tracy] 2003-05-15 09:22:56 PDT
seen with commercial trunk builds:

windows 2003-05-15-04-trunk
linux 2003-05-15-05-trunk
mac 2003-05-15-03-trunk

-load any page with a flash animation
notice that in many cases the entire page doesn't load. The flash animation also
doesn't load.  some pages have flash animations that are displayed in pop up
windows. Those windows just remain blank.
Comment 1 Peter Lubczynski 2003-05-15 09:50:38 PDT
did this happen in yesterday's builds?
Comment 2 Tracy Walker [:tracy] 2003-05-15 09:55:19 PDT
yesterdays early AM builds were fine
Comment 3 Peter Lubczynski 2003-05-15 10:01:10 PDT
ok, I'm updating now.....possible suspects from bonsai to try backing out
include the change to nsObjectFrame.cpp and the fix to bug 130265.
Comment 4 Peter Lubczynski 2003-05-15 10:08:01 PDT
hm...the changes to nsObjectFrame.cpp have to do with visibility. 

Tracy, do you "hear" Flash if going to a site like http://www.flashsound.com/
Comment 5 Tracy Walker [:tracy] 2003-05-15 10:17:25 PDT
no sound.  no animation to the right of the welcome message

yesterdays build had sound and animation of headphones and equalizer
Comment 6 Johnny Stenback (:jst, jst@mozilla.com) 2003-05-15 10:50:47 PDT
Are any javascript: URL's involved? If so, could be related ot the fix for bug
130265 (checked in yesterday).
Comment 7 Simon Montagu :smontagu 2003-05-15 10:54:32 PDT
Backing out bug 130265 from today's trunk build makes flash work for me.
Comment 8 Peter Lubczynski 2003-05-15 11:02:05 PDT
yup, I see a NPP_GetURLNotify("javascript:window.location[....] in the log. 
my build is almost done
Comment 9 Peter Lubczynski 2003-05-15 11:46:30 PDT
ok, I see what's going on in the debugger. When plugin specifies a target of
NULL in NPP_GetURL[Notify], the browser gives the response directly to the
plugin rather than displaying in a window. 

In this case, the plugin request a javascript: URL during initilization, while
we are still loading it's SRC url. In nsJSChannel::AsyncOpen, EvaluateScript
succeededs and the new code in StopAll is called, canceling the other data
stream to the plugin.

Any ideas on how to fix this or should we back out bug 130265 to get the tree open?
Comment 10 Peter Lubczynski 2003-05-15 12:09:19 PDT
Created attachment 123431 [details]
stack leading up to StopAll()
Comment 11 Peter Lubczynski 2003-05-15 12:16:20 PDT
commenting out the call to StopAll seems to do the trick
Comment 12 Johnny Stenback (:jst, jst@mozilla.com) 2003-05-15 12:24:12 PDT
Created attachment 123433 [details] [diff] [review]
Proposed fix, untested. Don't stop loads for non-document URI's
Comment 13 Peter Lubczynski 2003-05-15 12:32:16 PDT
Comment on attachment 123433 [details] [diff] [review]
Proposed fix, untested. Don't stop loads for non-document URI's

tested, Flash works great! r=peterl
Comment 14 Johnny Stenback (:jst, jst@mozilla.com) 2003-05-15 12:34:13 PDT
Comment on attachment 123433 [details] [diff] [review]
Proposed fix, untested. Don't stop loads for non-document URI's

Darin says sr=darin.
Comment 15 Peter Lubczynski 2003-05-15 12:40:33 PDT
fix in
Comment 16 Asa Dotzler [:asa] 2003-05-15 12:41:01 PDT
Comment on attachment 123433 [details] [diff] [review]
Proposed fix, untested. Don't stop loads for non-document URI's

a=asa (on behalf of drivers) for checkin to 1.4
Comment 17 Tracy Walker [:tracy] 2003-05-15 14:01:17 PDT
verified with respins on;
windows 2003-05-15-12-trunk
linux 2003-05-15-12-trunk
Comment 18 Darin Fisher 2003-05-15 18:05:51 PDT
*** Bug 205841 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.