JavaScript at Amazon.com fails to jump to next page of book sample pages

RESOLVED WORKSFORME

Status

--
major
RESOLVED WORKSFORME
16 years ago
14 years ago

People

(Reporter: tds, Unassigned)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4a) Gecko/20030401
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4a) Gecko/20030401

Many books at www.amazon.com have sample pages.  Mozilla does not
respond to clicks to go to the next page.  One can get to the pages
by looking at "See all 9 sample pages" and then chosing each individually.
This takes more work of course ...

Reproducible: Always

Steps to Reproduce:
1. Go to a book at www.amazon.com with sample pages, example above
2. click on the cover of the book or any sample page


Actual Results:  
Though the mouse (normally an arrow) becomes a hand (indicating
an active hyperlink) nothing happens upon clicking.

Expected Results:  
Jump to the next page of the sample pages.

This seems to be a javascript error.  The actual code on the page that
fails is:

<!--
document.writeln('<a href="">Next page&nbsp;<img src="htt
p://g-images.amazon.com/images/G/01/detail/dp-orange-arrow-right.gif" width=12 h
eight=11 border=0></a>');
// -->

that is, when I put my mouse over the page I get:
javascript:readerImg(1)
and this is the region of the html where that call originates.

Comment 1

16 years ago
WorksForMe using FizzillaMach/2003-05-16-08-trunk. Tom, can you still reproduce
this problem using a current nightly build?
Summary: javascript at amazon (www.amazon.com) fails to jump to next page of book sample pages → JavaScript at Amazon.com fails to jump to next page of book sample pages

Comment 2

16 years ago
WORKSFORME also on WinNT, Mozilla trunk binary 2003051508.
Reassigning to Browser-General until we get more info.

Tom: if a current build still doesn't work, are you getting any
errors in 

           Tools > Web Development > JavaScript Console  ?

(be sure to clear it of any previous errors first)
Assignee: rogerl → general
Component: JavaScript Engine → Browser-General
QA Contact: pschwartau → general
(Reporter)

Comment 3

16 years ago
It's going to take 1.5 hours to download a build :-(
before I do that I need to know which one is the right one.
ftp://ftp.mozilla.org/pub/mozilla/nightly/latest/
has
mozilla-mac-MachO.dmg.gz
but the alternative is
http://www.mozilla.org/releases/
  which would be "Mac OS X"
which should I use?

Comment 4

16 years ago
Get the build from <ftp://ftp.mozilla.org/pub/mozilla/nightly/latest/>. That
will be a "nightly" build you can use for testing this bug.
(Reporter)

Comment 5

16 years ago
I downloaded the nightly build:

Mozilla 1.4b
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4b) Gecko/20030518

I went to the URL given (above, amazon) and it still does not work.

|  if a current build still doesn't work, are you getting any
| errors in
|
|            Tools > Web Development > JavaScript Console  ?

Yes:

| Error: popup has no properties
| Source File: chrome://navigator/content/mailNavigatorOverlay.xul
| Line: 148

| (be sure to clear it of any previous errors first)

oops.  Try clearing that first... 
No errors appear when I click on the book cover.
NOTHING happens visibly.

So the error may be related to something else.

(By the way, howcome command N pops up a new browser but it is not blank?
My setting is for blank!  Instead I get http://www.mozilla.org/start/)
(Reporter)

Comment 6

16 years ago
I don't know if this is related (if not it would be a separate bug)
but I have been using a bookmark in my personal toolbar:

javascript:Qr=document.getSelection();if(!Qr){void(Qr=prompt('Enter word to find
in Merriam-Webster
Dictionary:',''))}if(Qr)location.href='http://www.m-w.com/cgi-bin/dictionary?'+escape(Qr)+'
'
In Mozilla 4a this would show a small window.  I type a word and it would
jump to the appropriate page in the dictionary.

This now fails.  The result now is that the url bar shows:
javascript:Qr=document.getSelection();if(!Qr){void(Qr=prompt('Enter word to find
in Merriam-Webster
Dictionary:',''))}if(Qr)location.href='http://www.m-w.com/cgi-bin/dictionary?'+escape(Qr)+'
'
and the window shows:
http://www.m-w.com/cgi-bin/dictionary?word
but it fails to jump.

So this is another javascript failure.
Please advise if it is the same or should be reported as a separate bug.

Comment 7

16 years ago
Tom, try testing using a new Mozilla user profile.
(Reporter)

Comment 8

16 years ago
I switched to my mozilla testing profile (which contains
just about nothing set) and it worked!

PLEASE HELP ME NOW!  I've been abandoned at this stage before!
I haven't a CLUE as to how to alter my main profile to fix such
an obsucre thing and I DO NOT WANT TO ABANDON my main profile
because I have it set just right.  Even if switching profiles
solves it, it is *still* a bug - another user would just give
up on mozilla at that point.

The dictionary problem was still there.  PLEASE: should
I report it as a separate bug or is there a mechanism
to do that?

Thanks!

Comment 9

16 years ago
Tom, did you ever hand-edit your prefs.js file or add custom preferences using a
user.js file?
(Reporter)

Comment 10

15 years ago
yes, see bug 183330.
That helped.

HOWEVER it probably is not the main source, as this bug came up more recently
I think.

Comment 11

15 years ago
here is the error I get from the js console (btw I have had this forever, I
always assumed it was Amazon screwing up)

Error: uncaught exception: Permission denied to set property HTMLImageElement.src

Comment 12

15 years ago
I switched profiles and it now works. Now can someone tell me what is wrong with
my profile?
Tom: WFM using Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6b)
Gecko/20031208, using Mac OSX 10.2.8.  I tested this using an existing profile
that I have had for some time. I am going to close out this bug as WFM.  If you
still see issues regarding profiles, that can be filed as a separate bug.  Thanks.

Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.