index.html not loading automatically

RESOLVED INVALID

Status

SeaMonkey
General
RESOLVED INVALID
15 years ago
13 years ago

People

(Reporter: notrustlist, Unassigned)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030507
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030507

Using the Mozilla Browser 1.4b, the index.html or index.htm page is not
automatically loaded when no file is specified in the URL.  Mozilla should be
doing this, as IE6 does.

Reproducible: Always

Steps to Reproduce:
1. using Mozilla Browser 1.4b, observe page loaded when you go to http://kynoch.ca
2. using Mozilla Browser 1.4b, compare to page loaded when you go to
http://kynoch.ca/index.html
3. using Internet Explorer 6, observe page loaded when you go to http://kynoch.ca
4. using Internet Explorer 6, compare to page loaded when you go to
http://kynoch.ca/index.html
5. note that the Mozilla Browser 1.4b is not automatically loading the
index.html page when it is not specified in the URL

Actual Results:  
The Mozilla Browser 1.4b results were different from each other.  The IE6
results were the same as each other.

Expected Results:  
Load the index.html or index.htm page automatically when no file is specified in
the URL.

This happens even after reloading the page a few times.

If you don't know there is an index page on a site, you would not know to try
entering it in the URL.  Basic users should not be expected to know this.
Actually, it's the server that maps foo/ to foo/index.html

That said, both urls load identically for me with a 2003-05-10-13 trunk CVS
build, and both are identical to what I see in other browsers.

Comment 2

15 years ago
Works for me too in build 2003051508 on Mac OS X 10.2.6
(Reporter)

Comment 3

15 years ago
I just tried changing the cache setting in my Mozilla Browser preferences so
that it compares the cache page to the page on the network EVERY TIME and it
fixed the problem.  Apparently, even though I had clicked RELOAD on the page
many times before, Mozilla was still using the cached version and not pulling
the index.html from the network for the updated version.

So, the problem was with my (the user's) cache settings.  But why, when I hit
RELOAD before, did the browser not pull the page from the network and update the
page in my cache?

Comment 4

15 years ago
Shift+reload will force an reload of a page.

reload will ask the server if there is a newer version of the page and depending
on the answer it will display the newer version or the cached version
(Reporter)

Comment 5

15 years ago
Since the problem was browser preferences and not browser operation, I'm closing
this problem report as INVALID.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.