Some frames are not loaded / shown correctly

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
16 years ago
14 years ago

People

(Reporter: helmut.leininger, Unassigned)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030515
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030515

Some frames of the above website seem to fail loading and are shown empty or the
pformer contents of the frame is not overwritten.

Reproducible: Always

Steps to Reproduce:
1. connect to http://www.ba-ca.com
2. click on OnlineB@nking Demo
3. after the fields have been filled, click Ok

Actual Results:  
There is a frame at the left, headed "OnlineB@nking". This frame is empty.

Expected Results:  
frame is empty.There should be a menu in the frame

Sometimes the erroneous frame shows up when you press reload. But this does not
work in all cases I have seen (not overwriting previous contents etc. but this
is in confidential pages).

Comment 1

16 years ago
I don't know for sure, but it may be a body onload timing issue.  In the onload 
of the main inner frame is this:

   sm_overlay('/sm_finanz.html','/hd_finanz.html');

Which does this:

function sm_overlay(url1,url2)
{
parent.sidemenu.location="/sidemenu/bach/"+top.sidemenuhead.language.toLowerCase
()+url1
    
parent.contenthead.location="/header/bach/"+top.sidemenuhead.language.toLowerCas
e()+url2
}

Oddly enough, the parent.contenthead line is executed just fine, but 
parent.sidemenu isn't.  No javascript errors in the console, either.

Comment 2

15 years ago
Hi Helmut, are you still experiencing this problem with the Bank Austria
Creditanstalt site in recent Mozilla builds? The menu you mention worked fine
for me, perhaps the bug was fixed or the website changed something in its code?
Thank you for any new information.
(Reporter)

Comment 3

15 years ago
I have not seen this problem again with recent builds, especially 1.5-RC2. For
me it seems to be solved.

Regards
Helmut

Comment 4

15 years ago
Ok, I'll mark this worksforme per Helmut's comment. Thanks for following up.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.