Unable to navigate menu items on http://www.richersounds.co.uk

RESOLVED DUPLICATE of bug 187565

Status

RESOLVED DUPLICATE of bug 187565
16 years ago
14 years ago

People

(Reporter: Mitch, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.4b) Gecko/20030516
Build Identifier: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.4b) Gecko/20030516

The Javascript menus are not naviagable in mozilla.
Works with IE, and also Netscape 4.x (any platform). 
Seems to be a bug with mozilla.
No javascript errors logged in the console.

Reproducible: Always

Steps to Reproduce:
1. http://www.richersounds.co.uk/index.php?f=itemntfl.php
2. Try navigating to any item (e.g. Speakers->Floorstanding)
3.

Actual Results:  
Nothing

Expected Results:  
Navigated to the respective page that the menuitem points to (as it does
in Netscape 4.x and IE)

No error messages makes this hard to diagnose.

Comment 1

16 years ago
Nothing doing for me either: Win2k, build 20030512

Comment 2

16 years ago
In my debug build I see

JavaScript error: 
http://www.richersounds.co.uk/turboshop/modules/turbonav/turbonav.js line 284:
syntax error
Error was suppressed by event handler

JavaScript error: 
http://www.richersounds.co.uk/turboshop/modules/turbonav/turbonav.js line 171:
thisI.type has no properties
Error was suppressed by event handler

Comment 3

16 years ago
Works for me, build 2003050714 (1.4b release) on Windows 2000

Comment 4

16 years ago
Doesn't work for me 
Mozilla 1.4b
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030507

Specifically the lower half of the menu doesn't work... the top half of menu
(the categories) works if you get the pointer in exactly the right place.

Comment 5

15 years ago
Mitch and Robert, are you still having this problem with JavaScript menus in
recent Mozilla builds? I just tried it and the site in question seemed to work
properly. Thank you for any new information.
WFM on WinXP trunk 2003102304.
(Reporter)

Comment 7

15 years ago
Sorry for the delay in responding Jon. 

Yes this problem is still happening on 20031020 build. 
The sub menu items are not selectable still (using Linux and gtk2 build
or Solaris and gtk1 build).

Comment 8

15 years ago
Hmm, this must happen only on non-Windows OS's. I did a better bugzilla search
and came up with bug 187565, which is a Tech Evangelism bug (meaning essentially
whoever reported it felt the bug was the site's fault for using especially
non-standard code rather than a problem in Mozilla). I don't know enough to say
if that's true for sure, but this bug is potentially a duplicate of that one if
it's true.
Seems like a non-Win bug, yes.. I suggest duplicating it against 187565, since
it looks like bad JS coding.

What do you say Mitch ?
(Reporter)

Comment 10

15 years ago

*** This bug has been marked as a duplicate of 187565 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.