edit bookmarks crashed mozilla

RESOLVED WORKSFORME

Status

SeaMonkey
Bookmarks & History
--
critical
RESOLVED WORKSFORME
15 years ago
13 years ago

People

(Reporter: wade.hampton, Assigned: Pierre Chanial)

Tracking

({crash, stackwanted})

1.4 Branch
x86
Linux
crash, stackwanted

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030508
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030508

While browsing, I selected edit bookmarks.  My last bookmark was for fftw.  I
clicked on 
it, then tried to "cut" using the right mouse button, but only "copy" was
available (cut was
grayed out).  I then tried moving it manually, and could do so.  Next, I
selected right mouse,
move bookmark, then selected the destination.  Mozilla crashed and all windows
closed.

System:  Laptop, RedHat 8, Mozilla 1.4b 

Note, I have had other mozilla crashes when trying to edit my bookmark file.

Bookmark file is 89K with multiple folders.  




Reproducible: Didn't try

Steps to Reproduce:
1. Start mozilla and open 3 windows:
  first with 6 tabs:  http://www.slashdot.org, http://news.google.com,
http://www.cnn.com,
                         http://www.foxnews.com, http://www.drudgereport.com,
http://www.bbc.co.uk

  second with 1 tab:  http://www.fftw.org

  third was email:  I had just selected get mail and it was downloading 20 or so
mails
2.  Add a new bookmark for fftw
3.  Click on mail window, get mail
4.  Click on edit bookmarks, select fftw, right mouse click, move bookmark,
enter a directory
5.  Mozilla crashed

Actual Results:  
First, I could not cut the bookmark (it was grayed out).
After using the right mouse -> move bookmark, it crashed mozilla

Expected Results:  
cut the book mark the first time
not crashed

No talkback crash ID
System is RedHat 8 on a laptop, most patches applied
Browser is Mozilla 1.4b
(Reporter)

Comment 1

15 years ago
The bookmark for FFTW had a red W icon in the bookmark folder.  It is the 
only one with an icon.  A subsequent bookmark of FFTW's page did not 
create a bookmark with a graphical icon.  

Comment 2

15 years ago
Wade, if possible, please attach a stack trace.
Keywords: crash, stackwanted

Comment 3

15 years ago
or a talkback ID
(Reporter)

Comment 4

15 years ago
The browser just closed.  Does it keep a stack trace or core
anywhere?  Does it keep a talkback ID?  I found neither
by looking in my ~/.mozilla directory.  Thanks

Comment 5

15 years ago
Similar Windows bug: bug 207940.

Comment 6

15 years ago
are you using an RPM build or a .tar.gz build?  RPM doesn't include talkback,
but you can get a decent stacktrace from gdb.  Some of the installer (.tar.gz)
build are also missing talkback).  To get a talkback enabled build, you can grab
one of these:

1.4 branch:
http://download.mozilla.org/pub/mozilla/nightly/2003-05-30-07-1.4/mozilla-i686-pc-linux-gnu-sea.tar.gz
or for a trunk build (1.5a):
http://download.mozilla.org/pub/mozilla/nightly/2003-06-01-22-trunk/mozilla-i686-pc-linux-gnu-sea.tar.gz

Comment 7

15 years ago
you might also try running from a terminal and see if it prints any messages
before crashing.
Product: Browser → Seamonkey

Comment 8

13 years ago
Old version, no response from reporter. No stack trace/TB. Resolving as WFM.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
Version: Trunk → 1.4 Branch
You need to log in before you can comment on or make changes to this bug.