Crashes when I rollover different menu items

RESOLVED DUPLICATE of bug 204781

Status

SeaMonkey
General
--
critical
RESOLVED DUPLICATE of bug 204781
15 years ago
13 years ago

People

(Reporter: Richard Hurt, Unassigned)

Tracking

({crash, stackwanted})

Trunk
x86
Windows XP
crash, stackwanted

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030512
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030512

When I go to the above page at T-Mobile and roll over one of the menu items (ie.
Product) and then move down to the secondary menu items (ie. Desktop Interface),
Mozilla blows up.  It even crashes Talkback.

I tried both 1.4b and the 2003051216 build and they both did the same thing. 
This used to work in 1.3 final.  I realize that this bug is with T-Mobile's
site, but it should not crash my browser.

BTW: I.E. 6.0 (SP1) fails in the same way, but it does give a little more
details on the specific error.

Reproducible: Always

Steps to Reproduce:
1. Open T-Mobile's Sidekick site
2. Roll over a primary menu item
3. Roll over a secondary menu item

Actual Results:  
Mozilla crashes and takes Talkback with it.

Expected Results:  
Not crashed and allowed me to enter my desktop interface.  If I am very careful
about not rolling over a primary menu it seems to work.

I am using the Pinball theme (as I have with all my latest versions of Mozilla).
(Reporter)

Comment 1

15 years ago
Created attachment 123501 [details]
T-Moble Javascript bug crash test case

The "T-Mobile.htm" file is the original file from the web site.  I reduced the
amount of junk to only the necessary stuff and made the "T-Mobile(small).htm"
file.  Also, Visual Interdev reports the problem as follows:

Error: 'target' is null or not an object
 Line: 138 
 File: WindowsNav6.js

Comment 2

15 years ago
URL is WFM Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4b) Gecko/20030515

Comment 3

15 years ago
This is not likely to be a bug in JavaScript Engine; reassigning
to Browser-General until we can get a stack trace.

I'm not crashing at the site or on the testcase with a Mozilla
trunk binary 2003051508 on WinNT.

Richard: would it be possible for you to download a Talkback-enabled
build from the ftp site. When you crash, please fill out the Talkback
form and submit it. Afterwards, you can run

      (path to Mozilla)/components/talkback.exe

to find the "indident number" of the crash. If you post the incident
number(s) here, we can look up the stack traces - thanks.
Assignee: rogerl → general
Component: JavaScript Engine → Browser-General
Keywords: crash
QA Contact: pschwartau → general

Comment 4

15 years ago
Oops, I missed this from above:

> Mozilla crashes and takes Talkback with it.

Ouch! I'll keep trying to reproduce this -

Comment 5

15 years ago
WorksForMe using FizzillaMach/2003-05-16-08-trunk.
Keywords: stackwanted

Comment 6

15 years ago
Looking at this more carefully: in any recent Mozilla trunk build
that I try on WinNT or Linux, the dropdown menus do not even appear!

For example, if I mouseover "Products" in IE6, it turns yellow
and a submenu appears: "Overview", "Phones", etc. In Mozilla, all I
get is the yellow color, but no submenu. The submenu under "Products"
is a <div> element with id "topNavElement0".

The visibility of this submenu is set by the following code in
https://www.t-mobile.com/masthead/js/BrowserAbsLayers/WindowsNav6.js:

function setVisibilityMethod(objRef,isVisible)
{
  objRef.style.visibility = isVisible;
}

function setDisplayMethod(objRef,displayValue)
{
  objRef.style.display = displayValue;
}


To make the <div> visible, the parameters that are passed in are
"visible" for |visibility|, and "" for |display|. Note |objRef|
is just |document.getElementById("topNavElement0")| here.


I don't know why I'm not seeing the submenus - there are no errors
in the JavaScript Console. Is anyone else having this problem ???

Comment 7

15 years ago
incident ID : 2016647
stack signature : nsEventStateManager::GenerateMouseEnterExit

Comment 8

15 years ago
> stack signature : nsEventStateManager::GenerateMouseEnterExit

dupe of "crash dragging bookmark groups to and from personal toolbar - Trunk [@
nsEventStateManager::GenerateMouseEnterExit]"

*** This bug has been marked as a duplicate of 204781 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 9

15 years ago
Richard: the duplicate bug was fixed on 2003-05-13, whereas your build
dated 2003-05-12. Could you try an up-to-date build and report back?
Has the crash gone away?

Meanwhile, I still can't see any submenus at the given URL,
https://www.t-mobile.com/mytmobile/sidekick/default.asp

When I mouseover "Products", for example, no submenu appears. Is anyone
else seeing the same problem? If so, that's another bug -
(Reporter)

Comment 10

15 years ago
WooHoo - This problem is now fixed as of build 2003051808!!!

However, I am not seeing the drop down submenus either.  Has this bug been filed?

Comment 11

15 years ago
cc'ing Madhur - do you think we should file a new bug on not seeing
the dropdown menus at this site, or is there already a Layout bug
on that problem?

Comment 12

15 years ago
let me check ....

Comment 13

15 years ago
a piece of code in the style sheet ..... 
https://www.t-mobile.com/masthead/css/masthead.css

says ....
/* HIDE Masthead Menus from Netscape */
.masthead-navElement {
	position:absolute;
	visibility:hidden;
}
/* end HIDE Masthead Menus from Netscape */

could there be some browser sniffing going on.
I am reading through the JS code to figure out if this could be true. 

that said.... i  could not locate a filed bug on  this issue 


Comment 14

15 years ago
https://www.t-mobile.com/masthead/js/BrowserAbsLayers/dynamic.js
is the javascript doing browser sniffing 

Comment 15

15 years ago
Looks like it's a bug on our end. Even if I spoof as IE6
in Mozilla, the submenus don't appear. In addition, an old
Mozilla build that I have (rv:1.3a) does show the submenus.

I have filed bug 206343,
"JavaScript submenus popup correctly, but cannot be seen"

Anyone who is interested should cc himself on that bug -
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.