admiralbet.com - no betting events displayed

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
16 years ago
4 years ago

People

(Reporter: testilus, Unassigned)

Tracking

Details

(Whiteboard: [havecontact], URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4b) Gecko/20030507
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4b) Gecko/20030507





Reproducible: Always

Steps to Reproduce:
1. Go to http://www.admiralbet.com/
2. Click on 'Betting'
3. Select *any* of the 'Active Betting Events'

Actual Results:  
Empty Betting Slip

Expected Results:  
Display detailed betting information for the selected event (quotes...)

Betting slip does work as expected when one of the 'Ending soon' or 'Popular'
links is used from the main page.

Comment 1

16 years ago
This is an evangelism issue.  The function showGames(itm) in 
AdmiralWeb/eventlist_output.jsp uses document.all:

function showGames(itm)
{
  objValue= document.getElementById("value" + itm);
  objHref= document.getElementById("href" + itm);

  if (1 == objValue.value)
    objValue.value = 0;
  else
    objValue.value = 1;

  param = "";
  if (document.all.chk.length)
  {
    for (i = 0; i < document.all.chk.length; i++)
    {
      //alert(document.all.chk[i].value);
      if (1 == document.all.chk[i].value)
      {
        var compid = document.all.chk[i].id + 'compid';
        objComp = document.getElementById(compid);
        param += 'compid=' + objComp.value + "&";
      }
    }
    if (param.length > 0)
      param = param.substr(0, param.length-1)
  }
  else
  {
    if (1 == document.all.chk.value)
    {
      var compid = document.all.chk.id + 'compid';

      objComp = document.getElementById(compid);
      param = 'compid=' + objComp.value;
    }
  }

  //alert("param="+param);
  if (param.length>0)
    objHref.href = 'gameslist.jsp?' + param;
  else
    objHref.href = 'gameslist.jsp?compid=0';
}

Comment 2

16 years ago
=> tech evangelism
Status: UNCONFIRMED → NEW
Component: Browser-General → Europe: West
Ever confirmed: true
OS: Windows 98 → All
Product: Browser → Tech Evangelism
Hardware: PC → All
Version: Trunk → unspecified

Comment 3

16 years ago
Moving it to right owner.

And contact mail : help@admiralbet.com
Assignee: general → nitot
QA Contact: general → brantgurganus2001
Whiteboard: [havecontact]
Summary: no betting events displayed → admiralbet.com - no betting events displayed
Walter: please mail them about the problem at first..

Comment 5

16 years ago
move tristans bugs to other
Assignee: nitot → other
Component: Europe: West → Other
QA Contact: brantgurganus2001 → other

Comment 6

8 years ago
INCOMPLETE due to lack of activity since the end of 2009.

If someone is willing to investigate the issues raised in this bug to determine whether they still exist, *and* work with the site in question to fix any existing issues, please feel free to re-open and assign to yourself.

Sorry for the bugspam; filter on "NO MORE PRE-2010 TE BUGS" to remove.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
Comment hidden (spam)
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.