contextual menu doesn't disappear when clicking on the main menu

RESOLVED DUPLICATE of bug 204770

Status

RESOLVED DUPLICATE of bug 204770
16 years ago
14 years ago

People

(Reporter: sebastien.deleuze, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr-FR; rv:1.4b) Gecko/20030507
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr-FR; rv:1.4b) Gecko/20030507

no details

Reproducible: Always

Steps to Reproduce:
1. Right on a page
2. for example, click on the bookmark item of the main menu


Actual Results:  
the contextual menu doesn't disappear

Expected Results:  
as when you click anywhere else, the contextual menu should have disappeared !
(Reporter)

Comment 1

16 years ago
There is another problem too : after you have right-clicked on the page, at the
first time you click on an item of the main menu ( bookmarks menu for example ),
this menu appears but close immediately. You have to click a second time on the
menu item to keep it opened.
(Reporter)

Comment 2

16 years ago
Sorry, another comment from me, but I think I have found what is wrong.

I think that when you have a contextual menu open and when you click on an item
of the main menu, the function that close the menu apply on the wrong menu, it
close the main menu instead of the contextual menu !

Comment 3

16 years ago
confirming Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4b) Gecko/20030516
seeing bug and behaviour from comment #1.
If a rightclick anywhere in the free space on this page, a context menue opens,
and closes, if I leftclick.
If I rightclick, the context opens, and I click on the mainmenu, Bookmarks,
I can´t close the context menue with leftclick. I´ve got to rightclick again,
before I can close the contextmenue with leftclick.

Sequence in the main menue: 1st click open+close, 2nd click open, 3rd click
close. This seems to be stored as state independent of the buttons in the menue:
If I open+close Bookmarks, and then click Tools, Tools opens.
If I close Bookmarks, and then click Tools, Tools open+closes.

Comment 4

16 years ago
undoubtedly related to bug 204770; probably even a dupe

Comment 5

16 years ago
Steps to reproduce are a little unclear. The bug is:
1) Right click anywhere in the content area of a browser window
   to get a context menu.
2) Left click another menu widget. The menubar or a folder popup
   on the personal toolbar will do.
3) The context menu can no longer be dismissed. Ever. (Except by
   loading a different page. Quitting the app also works.)
It's bug 204770, which I've just fixed by backing out the checkin that caused
the problem.

*** This bug has been marked as a duplicate of 204770 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
No longer depends on: 204770
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.