After highlighting and copying text left-click takes browser back one page in history

VERIFIED INVALID

Status

()

Firefox
Bookmarks & History
--
major
VERIFIED INVALID
15 years ago
10 years ago

People

(Reporter: Michael Grant, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6

When I highlight and copy text into the address bar the next time I use
left-click the browser goes back one page in the history.  Alternately it will
ignore the next right mouse-click.  A second try works fine. The indication that
the mouse click won' t work properly is that the highlighted text is   "stuck"
in its "already highlighted" color (grey).  Two clicks clears it up.  I have the
"Text Links" extension installed but the problem occurs even with it disabled or
not installed.

Reproducible: Sometimes

Steps to Reproduce:
1.Highlight any text (usually a non-link URL) and copy into address bar.
2. Go to URL.  Go back to previous page. Highlighted text should be in "already
highlighted" color.
3. Left-click, or right click

Actual Results:  
If you left click the browser will go back one page it the history.
If you right click nothing happens.

Expected Results:  
Left click (and hold) should let you highlight new text
Right click should bring up browser menu.

I have just (really, right- now) discovered another way to recreate the bug. 
Double click anywhere in text, and everything up to the last space is
highlighted.  Right-click and the menu which should appear does not. 
Right-clicking will then (maybe) take you back a page.  I have been trying to
make sense of this bug since I replaced 0.5 with the 05/10/03 nightly.

Comment 1

15 years ago
Michael, this is WFM using FB Gecko/20030610 in Windows XP. Unfortunately I
don't have a Linux box present, but just to make sure your environment is not
messed up: 

- did you tried this also after creating a new profile?
- does this problem also occur using latest MozillaFirebird nightly together
with a vanilla profile?
- can you also reproduce this using latest SeaMonkey nightly?

(Reporter)

Comment 2

15 years ago
WFM,
      This is Michael.  I haven't tried tried the latest seamonkey build (I
usually only use milestones).  I have however tested this bug against many
different profiles from a clean vanilla profile and slowly adding extensions up
to my custom profile.  The bug occurs in all instances, just as I described. 
Also the bug was not there in Phoenix 0.5 or earlier.
Michael Grant
P.S.: I haven't filed a bug report since Mozilla 0.98 so I hope this is (still)
the correct way.
(Reporter)

Comment 3

15 years ago
WTM, and blaker
As per WTM's suggestion I tried the latest nightly with various profiles.  BUG
IS GONE (fixed?). I am using the June 11 nightly.  Consider this one closed, I
guess.  
Michael Grant
(Reporter)

Comment 4

15 years ago
WTM, 
 Me again. After some fooling around I have determined that it is caused by the
Mouse Gestures extension (duh!). It seems obvious now and I don't know why I
didn't think of this earlier (I thought it might be the TextLink extension).
Unfortunately for me mouse gestures are a necessity.  I will bring it up with
the Mozgest people.  
Michael Grant

Comment 5

15 years ago
Michael, this is one (out of many) reasons, why we always ask for a new
installation of latest nightly, into a new directory together with a vanilla
profile - and thus without any extensions installed - just to make sure you've
got a clean installation to test. In any case it's good to hear the problem is
gone now! :)

=> resolving invalid per comment #3 + comment #4 since this was not a bug caused
by Moz.Firebird
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID

Comment 6

15 years ago
Verified.
Status: RESOLVED → VERIFIED

Comment 7

15 years ago
Verified.

Updated

10 years ago
Component: History → Bookmarks & History
QA Contact: asa → bookmarks
You need to log in before you can comment on or make changes to this bug.