If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

page scrolling (up/down) is broken

VERIFIED INVALID

Status

()

Firefox
General
--
major
VERIFIED INVALID
15 years ago
15 years ago

People

(Reporter: beanladen, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030507
Build Identifier: Mozilla Firebird 0.6 Linux i686

If typing either the page up/down keys or hitting the grey areas around the
scrollbar slider with the mouse, the page advances several times, making these
features unusable for page scrolling. It seems that smooth scrolling (which
works as intended for the arrows) is also applied for these elements, which, in the
view of usability, makes no sense at all and therefore is just wrong.
This is very visible for users and should be repaired soon.

Reproducible: Always

Steps to Reproduce:
1.load a longer page
2.type either the page down key or click into the grey areas below the slider
Actual Results:  
watch the pages flying by, unable to use page up/down for paging document

Expected Results:  
Document should scroll up and down pages one by one to be useful at all.
Don not apply smooth scrolling for page up/down.

This may not be a smooth scrolling problem only, as Mozilla 1.4x has the similar 
problem for the scrollbar areas (often scrolls two pages instead of one, but 
page up-down keys work).
(Reporter)

Comment 1

15 years ago
Argh ! Indeed the page is scrolling correctly, but it just looks like the
pages are flying by.
Sorry for the spam. INVALID
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID

Comment 2

15 years ago
v.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.