Closed Bug 206131 Opened 18 years ago Closed 16 years ago

Unthreaded View setting no longer saved per-folder

Categories

(SeaMonkey :: MailNews: Message Display, defect)

x86
All
defect
Not set
major

Tracking

(Not tracked)

VERIFIED WORKSFORME

People

(Reporter: rjl, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030516
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030516

Changing the View/Messages menu item has a global effect across all accounts.

Reproducible: Always

Steps to Reproduce:
1. Change the "View/Messages" menu item to All or Unread.
2. Select a different account and see that the change you made was global.

Actual Results:  
The menu item changes the view accross all accounts.

Expected Results:  
The menu item should only change the view for the current account.
*** Bug 206428 has been marked as a duplicate of this bug. ***
I can confirm this but want to request, that the setting should be per folder 
and not only per account.
In previous builds, the view setting only affected a certain account.
Either it was recently broken or it broke when I installed the spell checker.
This has been a problem since early Spring and still exists as of Build 20030513
Trunk 5...
This bug wasn't in 1.4a but is still in 1.4 branch.
And it hasn't anything to do with the spellchecker because I don't have it.
So it's a regression and I think this should be fixed for 1.4.
*** Bug 207419 has been marked as a duplicate of this bug. ***
I've looked around to find an earlier report, and couldn't.  I see the symptom 
in Win 2000, too.  Selecting the item from the menu is the same as selecting it 
from the MailViews dropdown, and that is not being saved on a per-folder basis, 
and is carrying over into folders (and newsgroups) that would otherwise be 
threaded.

I hope this wasn't by design.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
*** Bug 208495 has been marked as a duplicate of this bug. ***
Selecting View -> Threads -> Unread also provides a workaround for 207728.
this bug is annoying. Could it please get fixed until 1.4 final is released?
Flags: blocking1.4?
please note, that this is MOZILLA_1_4_BRANCH and IMHO it should be fixed.
Please make at least a comment on this problem.
It can be only a small problem, because this worked a long time before.
Thanks.
Still haunts 1.4rc3.  I agree it needs to be fixed for 1.4.
*** Bug 210747 has been marked as a duplicate of this bug. ***
Still present in 1.4 released version.
Flags: blocking1.4?
I can confirm this is still present in 1.4 release and should be fixed.
Confirmed in 1.4 final i.e. Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US;
rv:1.4) Gecko/20030624

Please, please, PLEASE fix!  This bug makes mail and news viewing very cumbersome.
Like many people, I prefer to see all mail messages but only unread news messages 
- having to switch between the two every time I change folders is a real nuisance.
This problem wasn't present in 1.3, though I'm not sure where in the 1.4
beta/pre series it appears.

Ideally this option should be applied per folder - this makes custom views more
useful.  Even per account (i.e. different for mail and news) would help.
Requesting blocking for 1.4.x, adding 'regression' keyword.
Flags: blocking1.4.x?
Keywords: regression
*** Bug 211971 has been marked as a duplicate of this bug. ***
Chase him up if you like, but Seth deliberately renamed the per-account
View/Messages/Unread to View/Threads/Unread, so that he could create a new
View/Messages menu which mirrors the View dropdown.
Status: NEW → RESOLVED
Closed: 18 years ago
Resolution: --- → INVALID
View/Messages/Unread != View/Threads/Unread

The functionality is not the same, a bug was introduced.

Fix it!
Reopening.  Neil, I believe you are misreading this bug; it has nothing to do 
with thread views.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
The functionality is deliberately different. For a global unread view use
View/Messages/Unread; for a local unread view use View/Threads/Unread.
The change in behavior from previous revs may have been deliberate,
but it is wrong.  You have removed functionality and utility. Fix it.
The point of this bug is that selecting an unthreaded View setting such as  
View|Messages|Unread  (which as of 1.4 maps directly to the MailViews dropdown) 
is then used for every folder which hasn't had a threaded view associated with 
it.

For instance:  my preferred view for mail folders is flat (unthreaded), sorted 
by date.  I would like to have the Inbox show the Unread messages (flat, by 
date), but I always want the Sent folder to show All (flat, by date).  This was 
possible in 1.3 without having to fiddle with views on every folder change; that 
is no longer possible in 1.4.  

This situation does indeed stem from the change that maps   View|Messages   
directly to the MailViews dropdown -- in 1.3, making a MailView selection held 
globally, and now the  View|Messages  menu does the same thing.  The UI is more 
consistent because of it. 

However, unlike bug 209534 and its dupes (from the same change), the desired 
functionality is not achievable by some other means; hence, a regression.

Neil has removed himself from the CC list, so I guess we're not going to get 
further input from him on this.  I still disagree that this bug is Invalid, but 
it may well be WontFix.

Michael Sierchio, you are mistaken if you think making demands is going to get 
results.
Thanks for your cogent reply -- I was merely strenuously objecting
to the fallacious reasoning behind the INVALID declaration.  

It was clearly a mistake.
Flags: blocking1.4.x? → blocking1.4.x-
I would like to stress that this setting should be per-folder, not per-account.
I always want to see my emails, but only want to see unread usenet. Another
example... I always want to see my email sorted by date, but want to see
my usenet sorted by thread and date.
Another way to put it, just in mail terms, is that I only want to see unread
Inbox messages but I ALWAYS want to see all in the Sent or Trash folders!  
*** Bug 219765 has been marked as a duplicate of this bug. ***
Updating summary to something a little clearer (I hope).
Summary: View/Messages/All|Unread is global :-( → Unthreaded View setting no longer saved per-folder
*** Bug 221480 has been marked as a duplicate of this bug. ***
For what it is worth, this problem carried over into the Firebird code as well,
and has not been resolved there either...

Any time estimates on?

Barry
*** Bug 221358 has been marked as a duplicate of this bug. ***
Request blocking for 1.6b.
Flags: blocking1.6b?
For ages I thought this was a bug until I read through this. IMHO it would be
clearer if View/Messages was moved down into the global section to try and
distinguish between global effect and local effect (which works just as I
expect) and mention this in the documentation :-)
For ages I thought this was a bug until I read through this. IMHO it would be
clearer if View/Messages was moved down into the global section to try and
distinguish between global effect and local effect (which works just as I
expect) and mention this in the documentation :-)
It is a bug. The ability to set All/Unread presentation for newsgroups in a
different manner than for mail accounts was effectively trashed by globalization
of this parameter. Documenting the change does not make it less of a bug.
Er, I can set it - I just use the thread menu and whether I have threading on or
sort by date mine seems to display read/unread fine in mail/news. I pretty much
ignore that messages menu now as it just seems to confuse the issue. I would
argue the ability is there its just not very obvious.
p.s. apologies for the dual post before!
I would still argue that the inability of both the Messages menu and the
pulldown to reflect the user's intent is an undesirable effect. The failure of
the pulldown menu to establish a localized setting is especially key, as this is
the most prominent means by which the user would establish the setting.

At a minimum, the redundant "All" and "Unread" options should be removed from
the Messages menu/pulldown to eliminate confusion.
I see your point about the View dropdown (had never used it myself :-) ) From my
point of view, I made it clearer for myself by moving View/Messages to above
View/MessageBodyAs and renamed Threads to Folder. While in no way perfect it
made it obvious to me!  
Flags: blocking1.6b? → blocking1.6b-
*** Bug 231005 has been marked as a duplicate of this bug. ***
*** Bug 231994 has been marked as a duplicate of this bug. ***
For those looking for an 'Unread' flat view stored on a per-folder basis:

Something I missed back in July -- I guess Neil was telling us this, but I was 
too dense to see:  View|Threads|Unread  does *not* put the folder into a 
threaded view.  

Since the fix for bug 72493, the   View|Messages|Threaded  toggle is present. 
(Or "restred" -- I gather it was in early versions of the original View|Messages 
menu).  With this, you can change the view to threaded if you like; and if it is 
already threaded, you can change the view to unthreaded.  The threadedness is 
stored per folder.

The 'All' and 'Unread' sub-menu items do not change the threading state.
The 'Threads with Unread' and 'Watched Threads with Unread' do.


I have to say, the way the menu names were changed was pretty poorly thought 
out.  Given the way the term 'thread' is used in the Mozilla Mail/News context, 
it is counterintuitive that  View|Threads|Unread  yields a flat view.  The 
confusion was heightened because both View|Messages and View|Threads have 'All' 
and 'Unread' items.  The confusion is evident in the discussions in bug 187990 
and bug 189543.


Since this bug was originally all about the Unread view, I wonder if there is 
any need to keep this bug open.  I think if support for applying and remembering 
a generic (flat) View|Messages setting is desired, that actually qualifies as an 
enhancement request rather than a bug.  At any rate, I'm clearing the 
'regression' flag on this bug -- anything you could do with View|Messages in 1.
3, can be done with View|Threads in 1.4 et seq; and the restoration of 
View|Messages|Threaded in 1.5 gives even more flexibility.

See also bug 219620 (which proposes moving the V|M|Threaded item, with a patch 
in progress); and bug 219787 (provided alternate behavior for sorting/threading 
by clicking on the column headers).  Also xref bug 135326.
Keywords: regression
Blocks: 236849
In Thunderbird 0.6, the view settings are global again and not local.
I select All in an email folder and Unread in an newsgroup folder, but it 
doesn't remember the setting per folder so I need to keep switching.
Product: Browser → Seamonkey
Assignee: sspitzer → mail
Status: REOPENED → NEW
This setting needs to be per-folder.  Regardless of whether I want to view my
messages in threaded or unthreaded fashion, simply switching between my Inbox
and my Sent folder requires changing this setting twice.
(In reply to comment #45)
> This setting needs to be per-folder.  Regardless of whether I want to view my
> messages in threaded or unthreaded fashion, simply switching between my Inbox
> and my Sent folder requires changing this setting twice.

I'm not sure which setting you're referring to, but: this bug was actually fixed 
sometime back in November.  The MailView setting is per-folder and sticky, just 
as are the settings for   View | Threads   and    View | Sort By.
Status: NEW → RESOLVED
Closed: 18 years ago16 years ago
Resolution: --- → WORKSFORME
I'm referring to the pulldown menu in the messages panel of the Mail window,
between "View:" and "Subject or Sender contains:".  The first three entries of
the pulldown menu are "All", "Unread", and "Important".

I just uninstalled Mozilla completely, and reinstalled with:

Mozilla 1.7.7 Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.7)
Gecko/20050414

When I switch between viewing the Inbox and a Sent folder, the pulldown menu
isn't sticky.  I have to change it to "All" when looking at "Sent", and I have
to change it back to "Unread" when I go back to my Inbox....
(In reply to comment #47)
> Mozilla 1.7.7 Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.7)

Quite right -- but it *is* fixed in current 1.8 builds, and the fix is very 
unlikely to be backported to the 1.7 branch.
Is there any way for me, as a user, to make the folder view settings global again?

I tried to find a preference with a likely name, but I am stuck with local, sticky folder views.

No longer blocks: 236849
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.