right-clicking on page then right-clicking on a bookmark will orphan the first context menu

VERIFIED DUPLICATE of bug 197112

Status

()

Firefox
Menus
--
minor
VERIFIED DUPLICATE of bug 197112
15 years ago
12 years ago

People

(Reporter: Adrian, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6

After you right-click on a web page, then go to the bookmarks toolbar and click
on a folder in there to open up a list of bookmarks. Right-click on one of those
bookmarks and notice how the first context menu jumps. Click anywhere outside of
the menu drop down to close the menu and cancel the second context menu. Now the
first context menu will remain, even when browsing to other pages, on screen at
all times until one of the following operations are performed:

1) Click on an item in the menu. Or
2) Right-click anywhere else on screen to create a new context menu.

After either event, the context menu behaves as it should once again.

In one special instance however, the context menu dissapears. That's on this page:

http://bugzilla.mozilla.org/show_bug.cgi?id=7696

The first context menu does not dissapear as it should.. it is merely invisible.
Right-click in the address bar to make it reveal itself once again.


Reproducible: Always

Steps to Reproduce:
1. Right-click to create a context menu on the main page.
2. Click on a folder in the bookmark toolbar and right-click on a link in that
folder. The first context menu may shift it's position suddenly.
3. Click outside of that second context menu and bookmark list to close it. The
first context menu will remain.
Actual Results:  
The first context menu refused to dissapear simply by clicking outside of it. It
became persistant as well, and I could take it to other web pages with ease.

Expected Results:  
The first context menu should have closed when I right-clicked on a bookmark.
Having more than one right-clicked context menu on screen is confusing and
should be avoided.

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 197112 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 2

15 years ago
mass-verifying
Status: RESOLVED → VERIFIED

Comment 3

15 years ago
Taking QA Contact as designated owner of Firebird-Menus. Sorry for bugspam.
QA Contact: asa → bugzilla

Updated

12 years ago
QA Contact: bugzilla → menus
You need to log in before you can comment on or make changes to this bug.