crash if I clear cache, cookies and history by using the "clear all" button.

VERIFIED WORKSFORME

Status

()

--
critical
VERIFIED WORKSFORME
16 years ago
12 years ago

People

(Reporter: KKuhlemann, Assigned: bugzilla)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: stacktrace needed for TB20320010E)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de-AT; rv:1.4b) Gecko/20030507
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-AT; rv:1.4b) Gecko/20030507

This occurs randomly about every fifth to tenth trial to clear the cache.
Talkback worked.

Reproducible: Sometimes

Steps to Reproduce:
1. Online session
2. tools - privacy - clear all information
3. clear cache stays marked and dont work

Actual Results:  
randomly one items stays in cache with internet content to be seen when opened
with notepad
sometimes crash of firebird

Expected Results:  
clearing of the cache without crash  

PC 2.8 GHZ 512 MB Ram with 4 OS
Win XP home
Mozilla 1.4b and Firebird installed
Using the minimalist theme, phoenity lite and pinball installed

Comment 1

16 years ago
Klaus, we have a different bug concerning crashes when clearing the cache, but I
can only reproduce this crash, if I've got another application (e.g. Windows
explorer) accessing the cache directory at the same time. 
may this be the cause of your crashes? For example sometimes you've got Windows
explorer open and viewing the content of the cache directory and if you clear
the cache during this time Moz. Firebird crashes - and some other time Windows
explorer is not open nor doesn't display the cache directory and if you clear
the cache then, no crash occurs?

Can you provide the talback ID created by Talkback? If you don't know how to get
the ID send me a mail so I can provide you the necessary steps to get it...
(Reporter)

Comment 2

16 years ago
I regret to have cancelled the talkback ID's installing the recent nightlies.
I think the applications opened while crash occured were the Java 1.4.1_02 JRE
which stays loaded till the browser is closed and the Windows dialup connection
via ndiswan. I'm sure that I did not open the cache folder or the profile via
Explorer. 
(Reporter)

Comment 3

16 years ago
The User agent on top is shown wrong: I used the
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-us; rv:1.4b) Gecko/20030516 build,
the final version in english. Sorry.

In the newer 20030517, 20030518 and 20030519 builds I was not able to provocate
crashes on the same unchanged WinXP system. But several times I was not able to
cancel the cache at once, it succeeded after closing and reopening firebird.  

 

Comment 4

16 years ago
Well, finally this bug here seems to be a duplicate one of bug #203528 since the
random crashes are gone somehow - hence I suggest duping this one and keep
focusing on bug #203528.

Klaus, if you disagree please feel free to reopen bug!

*** This bug has been marked as a duplicate of 203528 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 5

16 years ago
As of http://bugzilla.mozilla.org/show_bug.cgi?id=203528#c6 the crash reappeared
- hence this one might be different from bug #203528.

The talkback ID of the crash provided by Klaus via mail is TB20320010E.
Status: RESOLVED → UNCONFIRMED
Keywords: crash
Resolution: DUPLICATE → ---
Whiteboard: stacktrace needed for TB20320010E

Comment 6

16 years ago
Klaus, per http://bugzilla.mozilla.org/show_bug.cgi?id=206851#c6 one of the bugs
  causing Moz. Seamonkey / Firebird to crash has been fixed (see bug #206851 and
bug #196917) though the devs reopened this bug to find another solution -
perhaps your problem of crashing is gone with the currently checked-in fix?
(Reporter)

Comment 7

16 years ago
I myself had a crash because of this bug on Mozilla 1.4b release the 16. 5., 
TB ID 20145582G, and I think, that is different. In this case which is now 
fixed, the crash appeared using a link remaining on the screen after clearing 
the cache.
The crash meant in bug 206145 is released directly by the use of the "clear 
cache" or "clear all information" button in the preferences of Moz.Firebird, 
sometimes a second time having been unable to clear the cache.   

Comment 8

16 years ago
Klaus, you're right - bug #196917 covers the issue when clicking a link after
clearing the cache, but since your comment #2 where you mention that this crash
mostly occurs while Java opened and according to my Virus Scanner the java
plugin also accesses the cache, there was a slight chance for a relation between
the two bugs.

=> corrected typo in the summary and asked gordon to have a look on this, too.
Summary: crash if I clear cache, cooukies and history by using the "clear all" button. → crash if I clear cache, cookies and history by using the "clear all" button.
Does this still occur on current builds? If so, can we get a current Talkback ID
as I'm sure the one referenced is no longer available.

Comment 10

15 years ago
I was unable to repruduce this bug in: "Mozilla/5.0 (Windows; U; Windows NT 5.1;
en-US; rv:1.5a) Gecko/20030720 Mozilla Firebird/0.6"
taking QA contact, sorry about the bugspam
QA Contact: asa → mconnor

Comment 12

15 years ago
WFM Firebird 0.6.1 Win2K. Marking WFM based on that experience and on previous
comments.

-M
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago15 years ago
Resolution: --- → WORKSFORME
verified worksforme 2004-01-10
Status: RESOLVED → VERIFIED
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs,
filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → preferences
You need to log in before you can comment on or make changes to this bug.