preferences gui should default to 'general' section

VERIFIED WONTFIX

Status

()

Firefox
Preferences
--
enhancement
VERIFIED WONTFIX
15 years ago
15 years ago

People

(Reporter: Az, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030426 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030426 Mozilla Firebird/0.6

The preferences gui remembers which section was last accessed and when it is
opened, it defaults to that section.  It should IMHO default to the first
(general) section.

Reproducible: Always

Steps to Reproduce:
1. Tools > Options...
2. Click on one of the nav buttons down the left hand side. ie 'Themes'.
3. Close preferences window.
4. Tools > Options...

Actual Results:  
Preferences window remembers 'themes' section as last accessed and defaults to that.

Expected Results:  
Preferences window should default to 'general' section.

Comment 1

15 years ago
This is not a bug but an enhancement request!

=> reducing severity to RFE


btw: As SeaMonkey behaves differently than Moz. Firebird I suppose this
behaviour to be "intended" => suggesting WONTFIX.
Severity: trivial → enhancement

Comment 2

15 years ago
What's the rationale for your request to have it default to General rather than
last accessed? That is, why would it be better?
OS: Windows 2000 → All
(Reporter)

Comment 3

15 years ago
I confess I dont have anything concrete to support it other than to say that it 
just seems like it should.  Whenever you go into the preferences menu in any 
app i can think of it always starts with the first tab.

Examples of the top of my head:
IE - Tools > Options
Windows Desktop - Right Click > Properties

I have discusses it with a couple of non contributing FB users and several of 
them presumed it was just an issue that would be fixed as FB is still 0.6.  All 
of them agreed it should start at the first tab.

Comment 4

15 years ago
Ok, but from the usability point of view it's also not bad if the dialog opens
with the last used option - for example think about folks who need to change a
special item everytime after each session or before each session. Or the guys
who change their themes all the time... I believe it's ok for them to always
open with the themes Tab. I doesn't care about the tab that gets opened since I
only use the Options 1 or 2 times per month, but I'm sure the current logic has
also some advantages... :)

Comment 5

15 years ago
I agree with Erik; I don't use it much either but when I do it's often the
Connection pane that I use to set a proxy for a particular site and then when
I'm done I open up Options again and uncheck it.

That said I'm sending this to the forums for sounding out:
http://www.mozillazine.org/forums/viewtopic.php?p=93952

Comment 6

15 years ago
This was an explicit design decision made (an intentional behavior which differs
from SeaMonkey.) 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WONTFIX

Comment 7

15 years ago
v.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.