wachovia online billpay broken...

RESOLVED FIXED

Status

RESOLVED FIXED
16 years ago
4 years ago

People

(Reporter: kambo77, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030502
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030502

I do not know if this is a site or browser problem, but in wachovia online
billpay, billpay or express billpay, after entering your dollar amounts, the
'next' button does not submit the form.  nothing happens.  even though the
source seems to be onClick="javascript:submitForm()".  the back button works but
not next.  this has happened with 1.2,1.3,1.4b.   this is the only site that
does not work for me :)

Reproducible: Always

Steps to Reproduce:
1. wachovia online billpay, click express billpay
2. express billpay, select some targets
3. click next
2. enter an amount to pay someone
3. click next,

Actual Results:  
 form is not submitted

Expected Results:  
submit form and go to next page

Comment 1

15 years ago
Hi, are you still having problems with the Wachovia web site in recent Mozilla
builds? I unfortunately do not have a Wachovia account, so I can't test for
myself. Thank you for any additional information.
I can't test it either. Reporter: could you copy the HTML source and attach it
here ? Also, check your JavaScript Console for error-messages (go to Tools->Web
Development->JavaScript Console).
(Reporter)

Comment 3

15 years ago
ugh, I replied to this a while ago from hotmail, didn't go through?

well anyway it seems to a be a problem on wachovias end..they had two code
paths, a ie and netscape, but the user agent is just checking for "Netscape", so
for the last 6 months I was running mozilla with the user agent set to Netscape
that made the single pay and multi pay billpay screens work, I removed that
about a month ago because at least the 'single payment' seems to be working
again its just the 'multi payment' screen that is still broken using the default
gecko useragent, etc., but I can live without that, wachovia has told me mozilla
is not supported and it apparently is a problem on their end doing stupid things
with javascript - they used to have a much simpler, faster online page :(
(Reporter)

Comment 4

15 years ago
just a final comment about the javascript..they were doing something where each
keystroke you enter in an amount textbox would call a handler to update a
'total' field in another table, and they have two ways one for ie one for
netscape and the default mozilla user agent was using the ie way which wouldn't
work so the total never got increased above 0 so you couldn't submit the
form..that was/is on the multi payee page it is apparently gone from the single
payee page now...

Comment 5

15 years ago
Thank you for following up on this. Since it's a problem with the Wachovia site,
I'm sending the bug to Tech Evangelism who help convince sites to use proper
standards in their website design.
Assignee: general → english-us
Status: UNCONFIRMED → NEW
Component: Browser-General → English US
Ever confirmed: true
Product: Browser → Tech Evangelism
QA Contact: general → english-us
Version: Trunk → unspecified

Comment 6

15 years ago
I can confirm that Multiple Payments still does not work (Single payments now
works fine, as was mentioned), though this doesn't seem to work when using
Mozilla pretending to be Netscape OR Netscape 7.1.

Confirmed to be a problem with Mozilla 1.6b (on Win32 and OS X), Netscape 7.1
(on Win32 and OS X), as well as Firebird 0.7.

I can provide code for anyone interested...

Comment 7

15 years ago
It is broken for me too with Mozilla 1.5 on Solaris/Sparc.
However, Mozilla 1.1 (same platform) works fine with their billpay service.
I wonder if its a technical bug or some problem with the website.

Comment 8

15 years ago
I should note that when I said it didnt work for 1.5 Solaris-sparc, I meant
that I could log into the site, but when I selected "bill-pay", my browser
hung for a while and then I received "Internal server error" type output from
the browser.  Since Moz1.1/SolarisSparc worked with this site (although the
express pay did not work so well), I wonder if this is a new bug introduced
in later version.  I have filed a web-complaint with www.wachovia.com and will
post any explanation I receive.

Comment 9

15 years ago
My sister posted this on moznet:

something else that goes wrong in Mozilla is when I am online banking (Wachovia)
the "funds transfer" link stalls and then closes browser with an error
message... funds transfer works flawless in IE, but i dont use IE

She uses 1.4.1 on W2K.

Comment 10

15 years ago
Bug still exists, problem appears to be related to browser detection code.  Has
a simple detection mechanism - basically all code detected as being "Netscape"
uses one code set, everything else uses an IE code set.  Mozilla-based browsers
do not work, though Netscape does (despite my previous post).

Sent another message to website technical support.  I received only form letters
in response to previous mails.

Comment 11

14 years ago
Can someone on this bug who actually has a wachovia account please try it now.
I've checked their list of supported browsers here:

https://www.wachovia.com/personal/page/0,,10_476_934,00.html

and from that table is says that Firefox 1.0 should definitely be supported for
both Bill Pay and Online Banking.

Please let me know the results so I can close this is possible. Thanks.

Comment 12

14 years ago
They did improve online billpay about a year ago, but they still have a major
problem with online billpay, which is essentially the same problem as the
original  problem in the description.  

"Multiple Payments", the default billpay option, will not work properly in
Mozilla and Firefox browsers, though will in Netscape.  After filling in payees
and amounts to pay, the "Make Payment" button has no effect - you cannot submit
bill payments.

I reported this problem 8 months ago against Mozilla Suite, but was told that
Mozilla was not supported.  Now that they claim that Firefox 1.0 is supported,
perhaps they'll finally fix this - I'll send another request to fix this.

Comment 13

14 years ago
Despite what their compatibility matrix shows, Wachovia tells me that they do
not support Firefox with the "current version of Online Bill Payment".  Sometime
in the near future they're supposed to launch a new online banking system, which
supposedly will be available.  I'll add a new comment if this ever happens, and
document what the results are.
Ian, has Wachovia improved this at all in the last three years?

Comment 15

11 years ago
I ended up switching to another bank a while back, and when I switched they still weren't 100% compatible.  Perhaps someone who still uses them can confirm.
How close were they? Was it as bad when you switched banks as it was when you posted comment 12 or 13? Did they ever launch their promised "new version"?

Felix, is your sister still using Wachovia?

Bobby, how about you?
OS: Windows 2000 → All
Hardware: PC → All

Comment 17

11 years ago
They were pretty close - really, the only bugs they had left were fairly minor.  They hadn't launched the "new" billpay before I left (a bit over 2 years ago).  I'd be incredibly surprised if they don't fully support FF by now, but I can't confirm.

Comment 18

11 years ago
(In reply to comment #16)
> Felix, is your sister still using Wachovia?

Sis has been using SM branch for Wachovia billpay so long now she doesn't remember anything about it ever being broken.
FIXED per comment 18, then. If we get any new TE bugs on Wachovia from other users, we'll look into them then.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.