Quoted Plain text quoted messsage has the ">" displayed as blue bar

VERIFIED FIXED in M14

Status

MailNews Core
MIME
P3
normal
VERIFIED FIXED
19 years ago
10 years ago

People

(Reporter: pmock, Assigned: rhp (gone))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Build Date & Platform Bug Found:
 Win32 commercial seamonkey build 1999-12-01-13-m12 installed on P166 win98
 Linux commercial seamonkey build 1999-12-01-13-m12 installed on P200 RedHat 6.1
 MacOS commercial seamonkey build 1999-12-01-13-m12 installed on G3 MacOS 8.6

Overview Description:
 I set my user preference to use a plain text editor as my default compose
window. I reply to a plain text mail message and it quotes the text with ">"
characters.  I send the message to myself and view it.  The ">" displays as a
blue bar. I viewed my replied message in Communicator 4.7 and it displayed the
quotes as ">". The page source confirms that the ">" are present in the message.

 Content-Type: text/plain; charset=ISO-8859-1; format=flowed

It is a Messenger display problem because replied messages from 4.7 to 5.0 also
show up as blue bar.  This problem occurs under POP and IMAP.

Steps to Reproduce:
0) Deleted my previous mozregistry file and my existing profile.
1) Launch Mozilla with the -mail parameter
2) Enter a profile name and continue.
   Messenger launches and the mail wizard appears.
3) Enter all the necessary information for a POP or IMAP account
4) Exit.
5) Edit my prefs.js file.  Add the user_pref line:
    user_pref("mail.identity.id1.compose_html", false);
6) Start Messenger again
7) Send a plain text message to yourself and an account that you can view
the page source of the message in Communicator 4.7
8) Retrieve the mail message
   It is a plain text message
9) Reply ALL to the message again.
   It is quoted with ">"
10) Send the message
11) Retrieve and view the mail message
    The ">" characters display as a blue bar.

Actual Results:
The outer most ">" quoted text display with a blue bar.  It misleading because
initially I thought my message was being sent as rich text.

Expected Results:
I expect it to reads what's in the mail message and It display the ">" character
as a ">" character.

Additional Builds and Platforms Tested On:

Additional Information:
 If I view a message with multiple replies, the inner most quoted text display
correctly with ">" characters. The outer most ">" display with the HTML blue
bar.
(Reporter)

Updated

19 years ago
QA Contact: lchiang → pmock
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M13
(Assignee)

Comment 1

19 years ago
Will investigate.

- rhp

Comment 2

19 years ago
> It is a Messenger display problem because replied messages from
> 4.7 to 5.0 also show up as blue bar

Do I understand this correctly, that when you create a msg in 4.7 and reply to
it in 4.7 and the view it in Mozilla, you also see the bar?

> If I view a message with multiple replies, the inner most quoted text display
> correctly with ">" characters. The outer most ">" display with the HTML blue
> bar.

What happens, if you only reply in Mozilla (several times)? Do you see several
blue bars and no ">"s?

The blue bar is a feature. Mozilla doesn't sent real plain text, but
format=flowed, see bug #16398. You can see that in the content type header.
(Reporter)

Comment 3

19 years ago
You right Ben, there a different if you reply in 4.7 vs. 5.0.
 -When you create a msg in 4.7 and reply to it in 4.7 and the view it in
Mozilla, you do not see the blue bar.
 -When you create a msg in 4.7 and reply to it in 5.0 and the view it in
Mozilla, you do see the blue bar.

If you only reply in Mozilla (several times), the outer most ">" displays as a
blue bar.  The inner ">" display as ">". I do not see several blue bars and
I do see ">"s?
(Reporter)

Comment 4

19 years ago
In my last update, I was using the win32 commercial seamonkey build
2000-01-12-11-m13 installed on a P166 running Win98

Comment 5

19 years ago
Peter,
the behaviour is as expected. I would mark this bug INVALID, but I leave the
decision up to you or rhp.

However, you should see several blue bars after several Mozilla replies (and
*only* Mozilla replies). I would file a bug on *this*. (For the case you do, cc
Danial Bratell.)
(Assignee)

Comment 6

19 years ago
Hi Peter,
After doing some testing, I realized that this was fixed a while ago. It makes 
sense too because we used to be "hacking" in a <BLOCKQUOTE> for quoting 
operations. Now, we use the Editor's "InsertAsQuotation()" API calls so you 
get the correct results.

- rhp
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Reporter)

Comment 7

19 years ago
Verified as fixed on win32, linux, and macos using the following builds:
ftp://sweetlou/products/client/seamonkey/windows/32bit/x86/2000-01-24-01-M13/bac
kup/install.exe
ftp://sweetlou/products/client/seamonkey/unix/linux_glibc/2.2/x86/2000-01-24-01-
M13/netscape-i686-pc-linux-gnu.tar.gz
ftp://sweetlou/products/client/seamonkey/macos/8.x/ppc/2000-01-24-01-M13/NSMacIn
staller-M13.sea.bin
Status: RESOLVED → VERIFIED

Comment 8

19 years ago
Bug #29557 is related (if not a DUP).
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.