Closed Bug 206298 Opened 18 years ago Closed 16 years ago

[mozTXTtoHTMLConv] Structured text doesn't work with parentheses or non-ASCII text

Categories

(MailNews Core :: MIME, defect, P5)

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 106028

People

(Reporter: phil, Assigned: sspitzer)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312

If a message contains a set of words that must be underlined, but the last word
ends with a closing parenthesis or the first one starts with a openning one,
then the underlining is not working.
For example _some word_ is underlined
but in _that example (1)_ the underlining is not performed.

Reproducible: Always

Steps to Reproduce:
Confirming; replicated w/
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030516

Apparently plain-formatting occurs only for paired delimiters, on the same line, 
from "x_a"  to  "a_x" where:  
  x is whitespace or punct; 
  _ is underscore, slash or asterisk (underline, italic, bold)
  a is a letter: A-Z or a-z -- digits, non-ASCII letters don't qualify
Status: UNCONFIRMED → NEW
Ever confirmed: true
*** Bug 208522 has been marked as a duplicate of this bug. ***
Updating summary to encompass dupe.
Summary: Underscore (_) doesn't underline parenthesis delimited text → Underscore (_) doesn't underline parenthesized or non-English text
Adding "structured" to summary so I can find this next time I'm looking for it.
Summary: Underscore (_) doesn't underline parenthesized or non-English text → [Structured text] Underscore (_) doesn't underline parenthesized or non-English text
Works as intended <http://www.bucksch.org/1/projects/mozilla/16507/>
Avoiding to trigger in unintended cases (ascii-art etc.)

WONTFIX.
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → WONTFIX
Look at the attachment. This bug should not be closed.
This bug should be reopened as it's not fixed. Look at the duplicate 
http://bugzilla.mozilla.org/show_bug.cgi?id=208522
and the attachment above. 
It's not the same structure. Above are ASCII letters, below are russian ones. I
don't know a way to tell, if a charater is a foreign language letter or some
arbitary graphical character which is part of ASCII-art. Also, such a Unicode
function would probably be slow.
As documented, this is not designed to work in all cases, just the majority.
It's a non-essential, "nice to have" feature, esp. because other clients don't
bold either.
I cannot agree with you. This feature works fine in a lot of mail clients I've
seen with non-ASCII characters. Don't you think the Mozilla is and should be the
worst one of them or the whole word speaks only languages which can be fully
represented by ASCII set?
One more time. The usage of *word* or _word_ or other is common in Russian
e-mails and news. Half of Europe uses non-ASCII letters too. And are they the
people of the second sort?
Sorry for some expression.
> This feature works fine in a lot of mail clients I've
> seen with non-ASCII characters

How do these clients avoid to trigger the bolding in unintended cases like
ASCII-art? Please be concrete and precise.

> Europe .. are they the people of the second sort?

I am European, too.
Severity: normal → minor
Component: Mail Window Front End → MIME
OS: Windows 2000 → All
Priority: -- → P5
Hardware: PC → All
Summary: [Structured text] Underscore (_) doesn't underline parenthesized or non-English text → [mozTXTtoHTMLConv] Structured text doesn't work with parentheses or non-ASCII text
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---

*** This bug has been marked as a duplicate of 106028 ***
Status: REOPENED → RESOLVED
Closed: 16 years ago16 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.