-moz-opacity is not rendered in CSS <td> tags (at least)

RESOLVED INVALID

Status

()

Core
Layout: View Rendering
RESOLVED INVALID
15 years ago
15 years ago

People

(Reporter: Jeff Davidson, Assigned: roc)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 1.1.4322)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030507

In http://monkey.aafans.com/styles/monkey.css, the stylesheet for 
http://monkey.aafans.com, there is the following class:

TD.transparent {
	FILTER: alpha(opacity="60"); BACKGROUND-COLOR: #000000; FONT-FAMILY: 
verdana; FONT-SIZE: 11px; border: solid 1px; -moz-opacity: 60%;
}

The alpha-filter is for IE, while the -moz-opacity was meant to create the 
same effect in Mozilla/Netscape.  The effect works as expected on Mozilla 
1.3.1, which is shown in the top half of the image: 
http://monkey.aafans.com/mozillabug.jpg.  However, in the 1.4 beta version, as 
shown in the bottom half, renders it as though the -moz-opacity did not exist.

Reproducible: Always

Steps to Reproduce:
(Reporter)

Comment 1

15 years ago
Created attachment 123731 [details]
A picture of the http://monkey.aafans.com page in 1.3.1, and 1.4b
We have removed support for X% -moz-opacity values, since they didn't do what
people thought they did anyway, and since CSS3 opacity will only have numeric
values in the 0-1 range (which -moz-opacity supported and continues to support).
 Simply using "-moz-opacity: 0.6" should work fine on that site.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.