make <HTML> Source tab content in composer always LTR

RESOLVED WORKSFORME

Status

SeaMonkey
Composer
--
enhancement
RESOLVED WORKSFORME
15 years ago
13 years ago

People

(Reporter: Tsahi Asher, Unassigned)

Tracking

({helpwanted})

Trunk
Future
helpwanted

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0.2) Gecko/20030208 Netscape/7.02
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0.2) Gecko/20030208 Netscape/7.02

currently, when a RTL language pack is used, the "<HTML> Source" tab content
inherits the general RTL direction of the interface, and displays the code in
RTL. however, html is basicly in english, even if the page content is in a RTL
language, so the content of the <HTML> Source tab should remain in LTR even if
the interface is RTL.

Reproducible: Always

Steps to Reproduce:
1. aligning the interface to the right: add these lines to the file intl.css, in
the locale\en-US\global, in the en-US.jar file (the language pack file, in the
chrome folder):

window,dialog,wizard,page {
  direction: rtl;
}

menu { direction: rtl; }

outliner { direction: rtl; }
2.open a page in Composer
3.open the <HTML> Source tab

Actual Results:  
all the code is aligned to the right, with RTL directionality

Expected Results:  
the code should be aligned to the left, with LTR directionality.

Updated

15 years ago
Severity: normal → enhancement
Keywords: helpwanted
OS: Windows XP → All
Hardware: PC → All
Summary: [RFE] make <HTML> Source tab content in composer always LTR → make <HTML> Source tab content in composer always LTR
Target Milestone: --- → Future

Comment 1

15 years ago
Well, my find in html source fixes it for the body, but not for the doctype,
which would need some CSS love in the skin.

Comment 2

15 years ago
Interestingly with those rtl styles my source did not display correctly :-(
(Reporter)

Comment 3

15 years ago
you can also add them to your userChrome.css. but it should work: extract the
intl.css from en-US.jar with WinZip or other zip utility to your root folder,
while keeping folder structure, add the lines, and zip back, again keeping
folder structure.
What if you just add an extra rule to special-case the editor source view, like

#content-source {
  direction: ltr;
 }

or

.source-editor {
  direction: ltr;
 }

(this may be what comment 1 is referring to, I don't understand it)
Better still is

#content-source,
#doctype-text {
  direction: ltr;
 }

which fixes the doctype line as well. You might want to special case some of the
panes in DOM Inspector and JS Debugger, too. 
(Reporter)

Comment 6

15 years ago
that works.

i tried in the past to use css to solve bug 140577 comment 7, but it didn't work
(or my css is very poor).

regarding DOM inspector and venkman, since i'm not localizing them, i'd rather
they remain LTR entirely, as well as ChatZilla.
You can use the same approach for the main windows of chatzilla, venkman, DOM
inspector and any other tools that you don't want to localize, like this:

#chatzilla-window,
#venkman-window,
#winInspectorMain
 {
  direction: ltr;
 }

By the way, is the technique for making the UI right-to-left documented anywhere
in the Mozilla l10n docs?

Resolving this as WORKSFORME.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 8

15 years ago
>By the way, is the technique for making the UI right-to-left documented anywhere
>in the Mozilla l10n docs?

not that i'm aware of. i'll contact MLP staff about it.

Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.