Search Sidebar does not remember chosen search engine in advanced mode

RESOLVED FIXED

Status

SeaMonkey
Search
RESOLVED FIXED
15 years ago
10 years ago

People

(Reporter: Jakub Narebski, Assigned: shliang)

Tracking

({regression})

Trunk
x86
Windows 98
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4b) Gecko/20030507
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4b) Gecko/20030507

The Search sidebar does not remember chosen search engine in advanced search
mode (the mode in which you can divide search engines into categories, and
choose more than one search engine to do the search). It worked in Mozilla rv:
1.3 (Linux/X11). 

Reproducible: Always

Steps to Reproduce:
1.Change search mode to advanced.
2.Choose one category and select one of engines (check one of checkboxes)
3.Select other category or select other sidebar
4.Go back to the previous category/the search sidebar

Actual Results:  
All checkboxes are unchecked. No search engine is chosen.

Expected Results:  
The selection of search engines in categories should be persistent (as it were
in Mozila rv. 1.3).
(Reporter)

Updated

15 years ago
Summary: Search Sidebar does not remember chosen search engine → Search Sidebar does not remember chosen search engine in advanced mode

Comment 1

15 years ago
Seeing this in a recent nightly build (2003082404), but not in 1.4.

Comment 2

14 years ago
This regression from 1.4 is still in the latest nightly, hence it is in 1.5RC2
too. There is been low activity in this bug, is it because this bug is a dupe?

This is a very visible bug for the user in my opionion so it should be fixed in
a release version. Asking for permission to set this as a blocker for 1.5.
Flags: blocking1.5?

Comment 3

14 years ago
This is a regression from bug 190020 - the search panel tries to create invalid
resources which used to work but no longer does.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression

Comment 4

14 years ago
Created attachment 132539 [details] [diff] [review]
Proposed patch

Updated

14 years ago
Attachment #132539 - Flags: superreview?(rbs)
Attachment #132539 - Flags: review?(varga)

Comment 5

14 years ago
Comment on attachment 132539 [details] [diff] [review]
Proposed patch

>@@ -411,14 +411,9 @@ function SearchPanelStartup()
>   if (catDS) {
>     catDS = catDS.QueryInterface(nsIRDFDataSource);
>     categoryList.database.AddDataSource(catDS);
>-    var ref = categoryList.getAttribute("ref");
>-    if (ref)
>-      categoryList.setAttribute("ref", ref);
>     var engineList = document.getElementById("searchengines");
>     engineList.database.AddDataSource(catDS);
>-    ref = engineList.getAttribute("ref");
>-    if (ref)
>-      engineList.setAttribute("ref", ref);
>+    engineList.addEventListener("CheckboxStateChange", saveEngine, false);

nice cleanup, just make sure that you don't need engineList.builder.rebuild()
here
Attachment #132539 - Flags: review?(varga) → review+

Comment 6

14 years ago
Bug 215924, bug 218434, bug 213828, bug 208894, bug 187293 seems to be dupes of
this. 

Am I right? Please correct me if I am wrong, and if they are dupes, please mark
them as such, because I don't have such rights myself.

Bug 212703 is another ugly regression from 1.4 Is it related to when bug 206464
regressed?

If I am totally wrong here, then sorry for the bug spam.

Comment 7

14 years ago
As far as I can tell those bugs don't directly relate to advanced mode although
they may still have the same root cause [RDF.GetResource("", true) failing].

Comment 8

14 years ago
Created attachment 132603 [details] [diff] [review]
Addressed review comment

Actually this change turns out to be the fix to bug 212703

Updated

14 years ago
Attachment #132539 - Attachment is obsolete: true

Updated

14 years ago
Attachment #132603 - Flags: superreview?(rbs)
Attachment #132603 - Flags: review?(varga)

Comment 9

14 years ago
*** Bug 212703 has been marked as a duplicate of this bug. ***

Comment 10

14 years ago
Comment on attachment 132603 [details] [diff] [review]
Addressed review comment

r=varga
Attachment #132603 - Flags: review?(varga) → review+

Comment 11

14 years ago
Comment on attachment 132603 [details] [diff] [review]
Addressed review comment

passing your request to alecf@flett.org
Attachment #132603 - Flags: superreview?(rbs) → superreview?(alecf)

Updated

14 years ago
Attachment #132539 - Flags: superreview?(rbs)

Comment 12

14 years ago
Comment on attachment 132603 [details] [diff] [review]
Addressed review comment

sr=alecf
Attachment #132603 - Flags: superreview?(alecf) → superreview+

Comment 13

14 years ago
Fix checked in.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Updated

14 years ago
Flags: blocking1.5?
(Reporter)

Comment 14

13 years ago
*** Bug 224120 has been marked as a duplicate of this bug. ***
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.