"Bookmark This Link" does not create bookmark

RESOLVED FIXED

Status

SeaMonkey
Bookmarks & History
RESOLVED FIXED
15 years ago
14 years ago

People

(Reporter: Phil Pishioneri, Assigned: Pierre Chanial)

Tracking

({fixed1.4.2, useless-UI})

Trunk
fixed1.4.2, useless-UI

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: patch)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4b) Gecko/20030507
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4b) Gecko/20030507

While viewing a piece of mail or news article, selecting "Bookmark This Link"
from the context pop up menu does not work.

No bookmark is created.  An error is logged in the JavaScript Console:

Error: BMSVC has no properties
Source File: chrome://communicator/content/bookmarks/bookmarks.js
Line: 1547


Reproducible: Always

Steps to Reproduce:

Comment 1

15 years ago
Confirming with build 2003052004 and Windows XP.

The Bookmark Service is not initialized when the command for the context menu
item is executed.

I made a patch that does this initialization every time when oncommand for this
menu item occurs. This fixes the bug but since I'm not very experienced with
hacking Mozilla there might be a better way to fix it. I'll attach my patch in a
second.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: MacOS X → All
Hardware: Macintosh → All

Comment 3

15 years ago
I think it shouldn't slip our attention at 1.4 because it exposes a non working
feature. Anyway, there is already a patch. Is it possible for this to get a review?
Keywords: useless-UI
Whiteboard: patch

Updated

15 years ago
Attachment #123807 - Flags: review?(chanial)

Comment 4

15 years ago
Bug still apparent in Mozilla 1.4, Windows version.
stefan: can you chase reviews for this patch?

Gerv

Comment 6

15 years ago
Comment on attachment 123807 [details] [diff] [review]
Fix

looks good
Attachment #123807 - Flags: review?(pierre_tmp) → review+

Updated

15 years ago
Attachment #123807 - Flags: superreview?(bienvenu)
Comment on attachment 123807 [details] [diff] [review]
Fix

sr=bzbarsky
Attachment #123807 - Flags: superreview?(bienvenu) → superreview+

Comment 8

15 years ago
Comment on attachment 123807 [details] [diff] [review]
Fix

Asking for approval for 1.4.1 and 1.5. If it's to late for 1.4.1, please
consider this for 1.4.2.
Attachment #123807 - Flags: approval1.5?
Attachment #123807 - Flags: approval1.4.1?

Comment 9

15 years ago
Comment on attachment 123807 [details] [diff] [review]
Fix

a=asa (on behalf of drivers) for checkin to Mozilla 1.5
Attachment #123807 - Flags: approval1.5? → approval1.5+
trunk checkin done
Checking in mailWindowOverlay.xul;
/cvsroot/mozilla/mailnews/base/resources/content/mailWindowOverlay.xul,v  <-- 
mailWindowOverlay.xul
new revision: 1.254; previous revision: 1.253
done
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 11

15 years ago
Comment on attachment 123807 [details] [diff] [review]
Fix

too late for 1.4.1. if you'd like to see this in the next 1.4.x release please
set the approval1.4.2? flag.
Attachment #123807 - Flags: approval1.4.1? → approval1.4.1-

Updated

15 years ago
Attachment #123807 - Flags: approval1.4.2?

Comment 12

15 years ago
Comment on attachment 123807 [details] [diff] [review]
Fix

a=mkaply for 1.4.2
Attachment #123807 - Flags: approval1.4.2? → approval1.4.2+

Comment 13

15 years ago
fixed on 1.4.x branch.
Keywords: fixed1.4.2
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.