Mozilla Mail fails to parse UTF-8 encoded headers

RESOLVED DUPLICATE of bug 254519

Status

MailNews Core
MIME
RESOLVED DUPLICATE of bug 254519
15 years ago
10 years ago

People

(Reporter: Alexey Chernyak, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

({intl})

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
OS: Win2K
Build 1.4b

Whenever a friend of mine replies to my e-mails in UTF-8, Mozilla fails to parse
the From: field of his emails.
I'm not sure what mail client he uses.

When he sends messages in iso-8859-1 the header looks like:
From: "Polyanovskyi, Sasha" <fake@email>

When sent as UTF-8 the same header looks like this:
From: =?UTF-8?B?UG9seWFub3Zza3lpLCBTYXNoYQ==?=
	 <fake@address>

Mozilla seems to break this UTF-8 header in 2 parts and mis-handles it in the
following ways:

1. In the threadpane shows Sender as: Polyanovskyi
2. In message pane shows From: field as: Sasha <fake@address>
3. When replying to such email, in Composition window Mozilla puts To: fields
one of which is "Polyanovskyi" and another one "Sasha <fake@address>"

Ofcoarse when such composed message is sent, the "Polyanovskyi" addressee
bounces (very annoyingly), and the second one goes through.

None of this happens with iso-8859-1 header.

Interestingly, when opening this saved message in the browser, it seems to
handle the From: field correctly.

I'm attaching the troublesome message.
(Reporter)

Comment 1

15 years ago
Created attachment 123813 [details]
testcase
(Reporter)

Comment 2

15 years ago
For those wondering about inconsistencies, in the examples and testcase I
replaces his real e-mail address with a fake one.

Comment 3

15 years ago
I have yet to check RFC 2047 and RFC 822, but this is not likely to be Mozilla's
fault. The following is 

From: =?UTF-8?B?UG9seWFub3Zza3lpLCBTYXNoYQ==? <fake@address>

decoded to 

From: Polyanovskyi, Sasha <fake@email>

which is different from

From: "Polyanovskyi, Sasha" <fake@email>

Can you see the difference? Without quotatin marks, a bare comma is exposed
separating your friend's family name from the rest of the address. 

Stupid 'Internet Mail Service (5.5.2650.21)' apparently omitted quotation marks
when RFC-2047-encoding your friend's name in the form of 'last name, firstname'.
Moreover, there's no need to RFC-2047-encode it because it's all ASCII. A
work-around is to ask your friend to write his/her name 'firstname lastname'
without a comma (that is 'Sasha  Polyanovskyi').
Product: MailNews → Core

Comment 4

13 years ago
(In reply to comment #3)
> The following is 
> 
> From: =?UTF-8?B?UG9seWFub3Zza3lpLCBTYXNoYQ==? <fake@address>
> 
> decoded to 
> 
> From: Polyanovskyi, Sasha <fake@email>
> 
> which is different from
> 
> From: "Polyanovskyi, Sasha" <fake@email>
> 
> Can you see the difference? Without quotatin marks, a bare comma is exposed
> separating your friend's family name from the rest of the address. 

As discussed at the dupe, Mozilla is in fact misinterpreting the spec -- RFC2047 
encoded words are supposed to be handled as atoms -- that is, embedded commas 
were supposed to be parsed *prior* to decoding.

*** This bug has been marked as a duplicate of 254519 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.