Pop-up window is not blocked

VERIFIED DUPLICATE of bug 144726

Status

()

Firefox
General
VERIFIED DUPLICATE of bug 144726
15 years ago
11 years ago

People

(Reporter: Devin Henderson, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6

This page produces a pop-up window that is not suppressed, though 'Block
Pop-Ups' is selected in preferences.

I'm using Firebird 0.6.

Here is a text file that contains the source code of the page producing the
pop-up window:
<a
href="http://www.theinternet.info/downloads/freewareppc.txt">http://www.theinternet.info/downloads/freewareppc.txt</a>

Reproducible: Always

Steps to Reproduce:
1. Make sure 'Block Popup Windows' is selected under Preferences > Web Features.
1. Type www.freewareppc.com into the address bar of the browser.
2. Notice that a popup window quickly appears and then disappears behind the
original window.
3. Use the Windows task bar to switch to the popup window. Hmm... its an add
presented by a company called popupad.net.

Actual Results:  
A popup window appeared against my wishes!

Expected Results:  
Mozilla Firebird should have suppressed the popup.

Comment 1

15 years ago
Can confirm this using Moz. Firebird Gecko/20030519 on NT 4.0, but this happens
also using Mozilla SeaMonkey Gecko/20030519. Quite not sure whether SeaMonkey
and Moz. firebird use the same coding here? If so, this might be a SeaMonkey
issue...

Nevertheless exactly this popupad.net has been mentioned in reopened bug
http://bugzilla.mozilla.org/show_bug.cgi?id=126224#c112 

though I doubt bug #126224 to be the right bug report to fix this new problem
since this bug only has used to fix the problem with unrequested popups in
combination with img onload... 

Note:
Since this page uses a form submit to show the ad (flauncher.submit) it looks to
the browser like this is a "requested" popup...

Comment 2

15 years ago
Found bug #144726 which covers this problem, so if SeaMonkey and Moz. firebird
do use the same coding here, we can dupe this one because of bug #144726.
Keywords: qawanted
Whiteboard: DUPEME

Comment 3

15 years ago
AFAIK Seamonkey and Firebird share the code here and only differ in UI aspects.
I' duping this against bug 144726

*** This bug has been marked as a duplicate of 144726 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 4

15 years ago
mass-verifying
Status: RESOLVED → VERIFIED
Keywords: qawanted
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.