JRE needs proxy - authentification

RESOLVED DUPLICATE of bug 206545

Status

Core Graveyard
Java: OJI
RESOLVED DUPLICATE of bug 206545
15 years ago
7 years ago

People

(Reporter: Peter Lustig, Assigned: Darin Fisher)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6

We use Squid 2.4.6 Stable with smb_auth on Debian Woody as our proxy. The
Clients  run Windows 9x to 2k. While using IE with its own JVM you authenticate
to the proxy and alle the Java stuff works.
While using Mozilla or Phoenix with the SUN JVM 1.4.1 you authenticate to the
proxy. If you hit a site with Java applets, you need to authenticate a 2nd time
for the JVM. After this you can go to any site containing applets without having
to authenticate again. It is only a small issue but i guess our users won't
understand why they have to authenticate twice. ;-)

Reproducible: Always

Steps to Reproduce:
Works only if proxy with smb_auth is used
1. Start Mozilla
2. Enter a URL, authenticate to the proxy
3. hit a site containing Java applets
4. authenticate a 2nd time for the JVM


Expected Results:  
Should only ask once for authentication.

Comment 1

15 years ago
dupe of bug 206545

*** This bug has been marked as a duplicate of 206545 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Updated

15 years ago
Component: Networking: HTTP → OJI
QA Contact: httpqa → petersen

Updated

7 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.