chatzilla can't connect to hosts when proxy is in effect

RESOLVED INVALID

Status

Other Applications
ChatZilla
--
major
RESOLVED INVALID
15 years ago
13 years ago

People

(Reporter: philo vivero, Assigned: Robert Ginda)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030210
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030210

I've set up a proxy for HTTP, FTP, etc, but *NOT* for IRC (there is no IRC proxy
setting anyway) but when I try to use chatzilla to connect, it gets errors:
"connection to <host> timed out."

If I disable the proxy, then I can connect to the IRC host.

Reproducible: Always

Steps to Reproduce:
1. Setup proxy
2. Start chatzilla
3. Try to connect to IRC host

Actual Results:  
connection timed out error

Expected Results:  
Connect to IRC. Or, an option on proxy page saying "ignore proxy settings for
IRC" if there is such a thing as IRC proxy.
Do you have something in your socks proxy field ?
(Reporter)

Comment 2

15 years ago
Yes. I copied the name of the proxy to all fields. Does filling in the socks
proxy field then make chatzilla try to use that proxy? Is this bug just "user
doesn't know what socks does"?
(Reporter)

Comment 3

15 years ago
Sorry to add two comments, but I also was able to work around the bug (if now
that is indeed what it is) by putting the IRC host into the "do not use proxy
for..." entry widget.
Is this bug just "user doesn't know what socks does"?

Yes :-)
A socks proxy is different and can handle all kinds of connections. Mozilla
Mailnews will also use a socks proxy if you enter something there.
But you get connection Errors for all non http/https/ftp connections if your
proxy is no socks proxy.

We have a bug somewere to move the socks field in his own group.
It will of course work if you put the host in the no-proxy list because Mozilla
doesn't try to use a socks proxy for this connection

-> invalid

(and it will of course work
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
Product: Core → Other Applications
You need to log in before you can comment on or make changes to this bug.