Profile manager should not mention stored mail messages, bookmarks or other application-specific items

RESOLVED FIXED

Status

()

defect
--
minor
RESOLVED FIXED
16 years ago
11 years ago

People

(Reporter: deleteduser54318, Assigned: sipaq)

Tracking

(Blocks 1 bug)

unspecified
Points:
---
Bug Flags:
blocking1.8b5 -
blocking1.8rc1 -
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6

Since Firebird is only a browser, the profile manager should not mention that a
Firebird profile stores e-mail messages.

Reproducible: Always

Steps to Reproduce:
1. Start Mozilla Firebird with the Profile Manager. Read the accompanying text.

Comment 1

16 years ago
Confirming using Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.4b)
Gecko/20030601 Mozilla Firebird/0.6

There are 5 references to mail / messages related to profile dialogs:

- in {Select USer profile}
- in {Manage User Profiles}
- in {Delete Profile}
- in the 2 dialogs of the profile creation wizard labeled {Create Profile}
Status: UNCONFIRMED → NEW
Ever confirmed: true
Blocks: 214675

Updated

16 years ago
QA Contact: asa

Updated

15 years ago
Summary: Firebird profile manager should not mention stored messages. → Profile manager should not mention stored messages

Updated

15 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → Future
(Assignee)

Updated

14 years ago
Assignee: firefox → nobody
Severity: trivial → minor
Status: ASSIGNED → NEW
Component: General → XRE Startup
Product: Firefox → Toolkit
QA Contact: nobody
Summary: Profile manager should not mention stored messages → Profile manager should not mention stored mail messages
Target Milestone: Future → ---
(Assignee)

Updated

14 years ago
Summary: Profile manager should not mention stored mail messages → Profile manager should not mention stored mail messages, bookmarks or other application-specific items
(Assignee)

Comment 2

14 years ago
Posted patch patch v1 (obsolete) — Splinter Review
Easy patch, which removes application-specific wording from the profile
dialogs. This should also go on the branch, when it has been reviewed, since we
probably need that for XULRunner's first release as well.
Assignee: nobody → bugzilla
Status: NEW → ASSIGNED
Attachment #194813 - Flags: second-review?(bugs.mano)
Attachment #194813 - Flags: first-review?(mike)
Comment on attachment 194813 [details] [diff] [review]
patch v1

moving request to bsmedberg.
Attachment #194813 - Flags: second-review?(bugs.mano)
Attachment #194813 - Flags: first-review?(benjamin)
Attachment #194813 - Flags: first-review?(beltzner)

Updated

14 years ago
Attachment #194813 - Flags: first-review?(benjamin) → first-review+

Comment 4

14 years ago
Comment on attachment 194813 [details] [diff] [review]
patch v1

Actually, you're breaking my rule about l10n keys here: when you substantively
change the text, you should rename the key, so that localizers end up with an
orange tbox and know that they're supposed to re-translate the key.
Attachment #194813 - Flags: first-review+ → first-review-

Comment 5

14 years ago
Any chances to get this on branch? We (AviaryPL) would really love to see this
in 1.5's.
(Assignee)

Comment 6

14 years ago
Posted patch patch v2Splinter Review
This patch addresses the review comments from Benjamin.
Attachment #194813 - Attachment is obsolete: true
Attachment #198227 - Flags: first-review?(benjamin)
(Assignee)

Updated

14 years ago
Flags: blocking1.8b5?

Updated

14 years ago
Flags: blocking1.8b5? → blocking1.8b5-
Flags: blocking1.8b5- → blocking1.8b5?

Updated

14 years ago
Flags: blocking1.8b5? → blocking1.8b5-

Updated

14 years ago
Attachment #198227 - Flags: first-review?(benjamin) → first-review+

Comment 7

14 years ago
Didn't get on 1.5b2, so maybe there's a chance for 1.5 RC1?
Flags: blocking1.8rc1?
(Assignee)

Comment 8

14 years ago
Comment on attachment 198227 [details] [diff] [review]
patch v2

Asking for approval. Low-risk wording-only patch with l10n-impact.
Attachment #198227 - Flags: approval1.8rc1?

Comment 9

14 years ago
Comment on attachment 198227 [details] [diff] [review]
patch v2

too late for string changes.
Attachment #198227 - Flags: approval1.8rc1? → approval1.8rc1-

Updated

14 years ago
Flags: blocking1.8rc1? → blocking1.8rc1-
Checking in toolkit/locales/en-US/chrome/mozapps/profile/createProfileWizard.dtd;
/cvsroot/mozilla/toolkit/locales/en-US/chrome/mozapps/profile/createProfileWizard.dtd,v
 <--  createProfileWizard.dtd
new revision: 1.3; previous revision: 1.2
done
Checking in
toolkit/locales/en-US/chrome/mozapps/profile/profileSelection.properties;
/cvsroot/mozilla/toolkit/locales/en-US/chrome/mozapps/profile/profileSelection.properties,v
 <--  profileSelection.propertiesnew revision: 1.5; previous revision: 1.4
done
Checking in toolkit/profile/content/createProfileWizard.xul;
/cvsroot/mozilla/toolkit/profile/content/createProfileWizard.xul,v  <-- 
createProfileWizard.xul
new revision: 1.4; previous revision: 1.3
done
Checking in toolkit/profile/content/profileSelection.js;
/cvsroot/mozilla/toolkit/profile/content/profileSelection.js,v  <-- 
profileSelection.js
new revision: 1.10; previous revision: 1.9
done
(Assignee)

Updated

14 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Updated

13 years ago
Flags: in-testsuite-

Updated

12 years ago
Duplicate of this bug: 285409

Updated

11 years ago
Component: XRE Startup → Startup and Profile System
QA Contact: nobody → startup
You need to log in before you can comment on or make changes to this bug.