Internet Keywords: localhost goes to http://www.localhost.net.au/

RESOLVED DUPLICATE of bug 178123

Status

()

Firefox
General
--
major
RESOLVED DUPLICATE of bug 178123
15 years ago
14 years ago

People

(Reporter: Keyur Parekh, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030516
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030516

http://localhost:8085 is a fully formed URL and Firebird should go to that
instead it does some sort of find and instead takes user to
http://www.localhost.net.au/

Reproducible: Always

Steps to Reproduce:
1. Go to http://localhost:8085
2. Wait
3. You'll instead be taken to http://www.localhost.net.au/

Actual Results:  
Was taken to: http://www.localhost.net.au/

Expected Results:  
Should be displaying: http://localhost:8085
(Reporter)

Comment 1

15 years ago
I wanted to clarify that this happens when there isn't a service running at the
specified port. So in the example I gave, Firebird goes to
http://www.localhost.net.au/ when there is no service running on port 8085,
instead of displaying some sort of error message.

Comment 2

15 years ago
This is probably caused by Feature 'Internet Keywords', which redirects you to
the first matching result found for "localhost" by google.

So as your DNS resolving fails because of the not running service on the
specified port Moz. Firebird uses the 'I'm feeling lucky" redirect to the first
page google finds. 
Since this feature is switched on by default (See also
http://www.mozilla.org/docs/end-user/internet-keywords.html) this bug should get
resolved "invalid".

You can disable this feature by setting preference "keyword.enabled" = FALSE
after typing about:config in the address bar!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID

Comment 3

15 years ago
In fact I found another bug, which deals with the problem of using 

http://

URIs as Internet Keywords. As I second the reporter's argumentation in bug
#95390 to NOT use URI starting with http:// as IK I'll reopen this one and mark
it as duplicate of bug #95390!
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 4

15 years ago

*** This bug has been marked as a duplicate of 95390 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → DUPLICATE

Comment 5

14 years ago
mass-verifying
Status: RESOLVED → VERIFIED

Comment 6

14 years ago
REOPEN:
IK+localhost is getting its own bug.
Status: VERIFIED → UNCONFIRMED
QA Contact: asa → benc
Resolution: DUPLICATE → ---
Summary: should go to the URL but instead does some sort of find and goes to http://www.localhost.net.au/ → Internet Keywords: localhost goes to http://www.localhost.net.au/

Comment 7

14 years ago

*** This bug has been marked as a duplicate of 178123 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.