Closed Bug 206697 Opened 18 years ago Closed 15 years ago

Moving caret past an <input> with arrow keys in Composer (midas) is ineffective

Categories

(Core :: DOM: Editor, defect)

x86
Windows 98
defect
Not set
major

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: ebukiet, Assigned: mozeditor)

References

Details

User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3) Gecko/20030312

when you have an html source code that has the following in the body tag:
<textnode><input type="text" /><textnode>
where <textnode> represents a textnode (nodeType == 3)
with the mouse place the carret before the first textNode and then with the
arrow keys move the cursor to the right untill the <input> element.  continue
pressing the cursor-right key and you will see the caret cycle around in the
current textNode instead of proceeding  either into the <input>,  UI selecting
the <input> (with control handles for resize) or jumpimg to the next textNode.

Reproducible: Always

Steps to Reproduce:
1.copy the following HTML into the <body> section of composer (in html source mode):
aaa<input type="text" value="mytest">b
2. click back to WYSIWYG mode
3. place the caret inside the first textNode and press "home" key (or get to the
begining of the textNode using the mouse)
4. use the right-arrow key to move the caret to the right
Actual Results:  
caret circled to the begining of the current textnode

Expected Results:  
either into the <input>,  UI selecting the <input> (with control handles for
resize) or jumpimg to the next textNode.
I can confirm the actual result with
Mozilla/5.0 (Windows; U; Win98; de-AT; rv:1.4b) Gecko/20030507

I think that severity is "minor"

I think Target Milestone should be 1.5
Status: UNCONFIRMED → NEW
Ever confirmed: true
Blocks: caretnav
I am not able to reproduce this bug with Composer in Seamonkey 1.0a or 1.1a.

xref bug 162557
Summary: Moving selection (caret) with arrow keys in Composer (midas) is inneffective → Moving caret past an <input> with arrow keys in Composer (midas) is ineffective
No response from reporter  => WFM
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.