crash after loading http://www.happiness4all.net/ and switch Mozilla to the background

RESOLVED DUPLICATE of bug 108298

Status

()

Core
Plug-ins
--
critical
RESOLVED DUPLICATE of bug 108298
15 years ago
15 years ago

People

(Reporter: OstGote!, Unassigned)

Tracking

({crash, stackwanted})

Trunk
x86
Windows NT
crash, stackwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: TB20295770E, URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.4b) Gecko/20030521 Netscape/7.5 (Mozilla - In memoriam Netscape Communicator)
Build Identifier: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.4b) Gecko/20030521

Open that URL (note: page contains embedded midi sound – handled by Beatnik
Player V2.0.5.2 plugin on my systems) and after page is done, show about:cache
and switch to another program, so that Mozilla is in the background. Mozilla
crashes.

Reproducible: Always

Steps to Reproduce:
1. open http://www.happiness4all.net/
2. after page is done, open about:cache
3. switch to another program window (so Moz is now in the background)

Actual Results:  
Moz crashes.

Expected Results:  
Moz should not crash.

You can replace step 2 with reloading page or minimize Moz, in most cases this
leads to a crash too.

Tested under Win 2000 and Win NT 4.0:

Mozilla build 2003052108 winNT4
TB20332594Z

Mozilla build 2003052008 win2K
no talkbacks, installer did not contain TB

Mozilla build 2003051512 winNT4
TB20295770E

Mozilla Rel. 1.4b win2K
TB20280242X, TB20280284Z, ...

Netscape 7.02 Compact win2K (step 2 with reloading page)
TB20295941X

Comment 1

15 years ago
do you crash after upgrading to Beatnik 2.2 ?
http://plugindoc.mozdev.org/windows1.html
See also bug 108298.
Keywords: crash, stackwanted
Whiteboard: TB20295770E
(Reporter)

Comment 2

15 years ago
I upgraded to Beatnik Player v2.2.1.100 and I don't crash anymore. I knew it ...
something with the plugin. Thanks.

If you don't want to do the stack analysis anyway: Should I dupe it against bug
108298 or marking invalid (outdated plugin)?

Comment 3

15 years ago
Old Beatnik plug-in used an outdated plug-in model and crashed. I don't think we
need the stack.

*** This bug has been marked as a duplicate of 108298 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Component: Browser-General → Plug-ins
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.