If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

document.form1 has no properties.can't display this page

RESOLVED WORKSFORME

Status

Tech Evangelism Graveyard
Chinese-Simplified
RESOLVED WORKSFORME
15 years ago
3 years ago

People

(Reporter: gzk, Unassigned)

Tracking

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; zh-CN; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; zh-CN; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6

first goto http://www.bol.com.cn to login.
When browser goto http://www.bol.com.cn/cgi-bin/bol/bol/acm_ab_000.jsp,the page
is  blank. I use javascript console , it records that document.form1 has no
properties.


Reproducible: Always

Steps to Reproduce:
1.goto http://www.bol.com.cn
2.register if you haven't an account.
3. login ,then the bug will happen at the URL
http://www.bol.com.cn/cgi-bin/bol/bol/acm_ab_000.jsp


Actual Results:  
The page is blank.there is nothing at all.

Expected Results:  
should display it correctly.
(Reporter)

Comment 1

15 years ago
Created attachment 123975 [details]
the bad page
(Reporter)

Comment 2

15 years ago
Created attachment 123976 [details]
the good page
Keywords: qawanted

Comment 3

15 years ago
This is probably evangelism.  Their js code doesn't distinguish between old and 
new Netscape, so they're using older properties:

if(!mie)
{
  pageX=window.pageXOffset;
  pageW=window.innerWidth;
  pageY=window.pageYOffset;
  pageH=window.innerHeight;
}

IIRC, window.pageXOffset & pageYOffset are no longer properties of the Moz 
window object.

Comment 4

14 years ago
I'm moving this bug to Tech Evangelism. Sterling is correct, the site uses
Internet Explorer specific (or at best, non-standard) behavior which is not
something the Mozilla developers are willing to support. Specifically, the page
is giving the "document.form1 has no properties" error because the script is
running in the <head> tag. Scripts located there get run before the body of the
page is loaded, so at that point form1 does, in fact, have no properties since
they haven't been created yet.

Please do e-mail the administrator of the site and suggest that he/she would get
more customers by supporting non-Windows and/or non-IE users.
Assignee: general → chinese-simplified
Status: UNCONFIRMED → NEW
Component: Browser-General → Chinese-Simplified
Ever confirmed: true
Keywords: qawanted
Product: Browser → Tech Evangelism
QA Contact: general → chinese-simplified
Version: Trunk → unspecified
404
Mozilla/5.0 (X11; Linux i686; rv:23.0) Gecko/20100101 Firefox/23.0
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.