Fonts in menues, in folder pane and in message overview pane (but not message pane) are TOO SMALL to be readable

RESOLVED DUPLICATE of bug 18454

Status

defect
RESOLVED DUPLICATE of bug 18454
16 years ago
13 years ago

People

(Reporter: kz, Assigned: sspitzer)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030507

Fonts in menues, in folder pane and in message overview pane are TOO SMALL to be
readable. The message pane itself it OK.

Please see <http://kz.kz/mozillabug/smallfont/> for screen dumps.

Note: I've reduced the system font size to 80%, Mozilla seems to reduce this
further.

Reproducible: Always

Steps to Reproduce:
1. Start Mozilla, either the browser or MailNews
Actual Results:  
Everything looks OK. Only, most texts are too small to be readable.

Expected Results:  
Same text size in menus etc as in "all" other programs.
The portions of Mozilla containing the small text you complain of are sized
using points. The meaning of a point is dependent upon the system DPI setting.
Smaller DPI settings produce smaller point sizes and vice versa. When you
changed the system fonts to 80%, you reduced the DPI, thus reducing the size of
the fonts in controls and the headers and folders panes. If for some reason you
require the system setting of 77 DPI for your other apps, but need the indicated
Mozilla fonts to be larger, then you will need to learn how to make use of the
userChrome.css file that may or may not currently exist in your profile's chrome
directory. As a starting point, try putting this into that file:

     * {font-size: 9pt;}

It will most likely not be suited without customization, but you will be able to
see the effect. Make sure to restart Mozilla cold after modifying userChrome.css.

Your system DPI also affects web pages that size text in points. Again, on web
pages as in the chrome, smaller DPI means smaller text.
http://members.ij.net/mrmazda/auth/PointsDemo.html can help you decide upon an
appropriate system DPI setting.
Thank's, manipulating userChrome.css in the profile counteracts the problem,
making the fonts large enough.

Strangely enought, only MozillaFirebird and Mozilla of the programs installed on
this computer are having this problem. 
The duplicate is about folder pane / thread pane text; bug 206702 is about menu 
font size, among others.

See also bug 124510, bug 180198, bug 206443, bug 207593 for other bugs specific 
to other parts of the UI.

*** This bug has been marked as a duplicate of 18454 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.