Bookmarks on menu bar don't work after opening new window

RESOLVED FIXED in Firebird0.8

Status

()

--
major
RESOLVED FIXED
16 years ago
13 years ago

People

(Reporter: wayne.pascoe, Assigned: hyatt)

Tracking

unspecified
Firebird0.8
PowerPC
macOS
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6

On Mac OS X, closing the main browser window (red x) doesn't terminate the
application. The application is still live in the dock. When you then open a new
window, bookmarks on the toolbar no longer function. They also don't have the
Open in Tab option that they do when you open the app for the first time.

This only happens if you close all browser windows and then open a new one. This
does not happen when you just minimize the window

Reproducible: Always

Steps to Reproduce:
1. Start firebird
2. Close the main browser window (red x)
3. Open a new window (click icon in dock and hit Apple-N)
4. Try and access bookmark from personal bookmarks on tool bar

Actual Results:  
The open in tab option after a separator was no longer there and clicking a
bookmark did not work.

Expected Results:  
The bookmarks should appear as they did when the app was first opened and
bookmarks should have worked.

Comment 1

16 years ago
Confirmed using Firebird/Mac/2003-05-16 (0.6).
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

16 years ago
Wayne, does this problem only occur, if you've got a blank page as start page? I
just wonder if this is a duplicate of bug #206933
(Reporter)

Comment 3

16 years ago
This bug occurs even if I have a site as my start page. I have
http://www.google.com/ as my start page, and this is displayed in the new window
that is opened when bookmarks fail to work.

Comment 4

16 years ago
*** Bug 208051 has been marked as a duplicate of this bug. ***
taking QA contact, sorry about the bugspam
QA Contact: asa → mconnor
(Assignee)

Comment 6

16 years ago
--> me
Assignee: chanial → hyatt
Target Milestone: --- → Firebird0.7

Comment 7

16 years ago
*** Bug 216109 has been marked as a duplicate of this bug. ***
*** Bug 214570 has been marked as a duplicate of this bug. ***

Comment 9

16 years ago
hey, just as a note, in bug 214570 the reporter is saying that bookmarks don't
work when there are no windows open (also true), so perhaps the summary should
be updated to include both cases.

Comment 10

16 years ago
sorry for the spam, but i'd thought i'd point out a workaround.  if you close
all browser windows, the first window you open will be busted (this bug as well
as bug 206456 occur), but if you open another browswer window (while this busted
one is open) the new window works properly.
*** Bug 217295 has been marked as a duplicate of this bug. ***

Updated

16 years ago
Target Milestone: Firebird0.7 → Firebird0.8
*** Bug 217763 has been marked as a duplicate of this bug. ***

Comment 13

16 years ago
*** Bug 217829 has been marked as a duplicate of this bug. ***

Comment 14

16 years ago
I can confirm this wrong behavior in nightly build of user agent: Mozilla/5.0
(Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5b) Gecko/20030827 Mozilla
Firebird/0.6.1+/jtalkington-nightly

Comment 15

16 years ago
*** Bug 217993 has been marked as a duplicate of this bug. ***
*** Bug 218350 has been marked as a duplicate of this bug. ***

Comment 17

16 years ago
Confirming on latest nightlies:
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6a) Gecko/20030928
Firebird/0.7+/jtalkington-nightly

I also did some work on trying to nail down this bug. Here are my findings:

Bookmarks don't work at all on a new window after closing all windows. It's not
just the toolbar, but also things in the Bookmarks menubar.

Manage Bookmarks does open the Bookmarks Manager, and you can launch bookmarks
from the manager. However, changing or adding a bookmark doesn't fix the
bookmark functionality.

But, here is how you fix it: launch another new window, once you have the first
one open. Bookmarks work in the new window. This does not fix bookmarks in the
original window, though. Closing the first window does not affect the second,
fixed window.

Hence, a workaround is open another new window (Cmd-N) and close the first one.

Hope this helps!

Comment 18

16 years ago
*** Bug 222371 has been marked as a duplicate of this bug. ***

Comment 19

16 years ago
*** Bug 222663 has been marked as a duplicate of this bug. ***

Comment 20

16 years ago
After opening a new 'broken' window (blank), I am able to click Help>Release
Notes and navigate by clicking links in the page, but the forward/back buttons
in the tool bar are not active.  

As others have found, bookmarks on the toolbar did not work in this situation,
nor was there a 'open in tabs' option.

Comment 21

16 years ago
I wonder if this is related to bug #205199 ?
*** Bug 205199 has been marked as a duplicate of this bug. ***

Comment 23

16 years ago
Fixed 20031024 Firebird/0.7+ (see bug 223331). Needs to be set as fixed or duped
to that bug.

Comment 24

16 years ago
Yes, this seems to be fixed in build 20031026 (Firebird 0.7.1), which is a
highly recommended update for all Mac users.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
You need to log in before you can comment on or make changes to this bug.