If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Unable to copy and paste url

RESOLVED DUPLICATE of bug 133439

Status

()

Core
XUL
--
major
RESOLVED DUPLICATE of bug 133439
15 years ago
12 years ago

People

(Reporter: Mel Dubnick, Assigned: jag (Peter Annema))

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030507
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030507

The copy and paste functions -- both through drop down menus and via keys -- is not functioning. Checked by performing same functions browser, and all checks okay.

Reproducible: Always

Steps to Reproduce:
1. Linked to any url.
2. Attempt copy via ctrl-c or through dropdown menu; seems ok
3. Attempt to paste into url location or any other program (e.g., notepad, word) does not work.

Actual Results:  
No paste.

Expected Results:  
Should have transferred copy.

Comment 1

15 years ago
I also experience this on NT4 sp6a (Dual CPU) 
My symptoms are as below, except that it is actually intermittent.
After multiple attempts, it will eventually copy and paste...if I don't give up
in frustration.
This occurred on previous versions as well - but as it is such a hideous bug, I
assumed it would be unable to escape notice. 
I'm unable to apologise for not reporting it earlier - as I'm a self-righteous
prat who thinks the bugzilla reporting system puts too much onus on the user to
'research' their bug-report before posting. I understand the operational
dificulties of trying to tie together multiple similar bug-reports  - but the
current system is 'scary' to wimps like me - so phenomenally horrible bugs like
this are allowed to survive for so long. 
This bug has got to be the 2nd last reason I still steam up Internet Explorer -
the other being the need to use that terminal services thing.. 
Copy and paste not working shakes the very foundations of the users trust in
working with their system - sounds like I'm being over dramatic, but seriously -
one spends years getting used to certain things that 'just work', a backward
step in this basic functionality is a serious bug indeed.  
If copy and paste fails in the address bar - how can I trust it when working
with forms, or in news/email? 
This bug should be changed to critical. 
Summary: Unable to copy and paste url → Unable to copy and paste url

Comment 2

14 years ago
A reliable way to reproduce the bug on 1.4rc3 Linux is:

1. Select and copy some text on a web page
2. Open a blank new window
3. Try to paste the text into the address bar

Pasting fails, but succeeds after a mouse click has been made in the blank area
of the new page.
Reporter: please try this using a recent nightly build from
<http://ftp.mozilla.org/pub/mozilla/nightly/latest/>. If it works, please
resolve this bug as WFM. Thanks !

Comment 4

14 years ago
I cannot reproduce this anymore?

I am however experiancing some *random problems* using copy/paste as described,
but cannot reproduce that using the steps described.
Describe "random problems" ?

WFM on WinXP SP1 trunk 2003092404.

Comment 6

14 years ago
Problems which only appears on a random basis.

It prevents me from copying anything from the adressebar, but copy/paste in
windows works fine at the same time.

Damn annoying, I've only had this problem in Windows XP

I can't reproduce it, I do not know what is causing it

Comment 7

14 years ago
I am on Linux Red Hat 8,
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030701

I have noticed this problem only since installing Mozilla 1.4 (up from 1.2.x) a
couple weeks ago.

Paste into URL window does *not* work when window is first created (i.e. control
1 when in mail starts browser, with focus in the url window -- it is a blinking
cursor anyway).  Even clicking in the URL window does not help.  Paste is not an
available option (as that point) in the Edit menu.

However, another poster pointed out that if you click somewhere in the main
browser window and then click back in the URL window and try to paste again, it
will work.  I have tested and this way of doing it does work for me.

The *copy does work*.  The problem has something to do with either the *paste*
or with the *focus*.

Please note that this bug is the same as 210007 -- somebody should consolidate them.

I am cross-posting to both bug numbers.

Jay Smith 

Comment 8

14 years ago
I hesitate to add this here, but my problem seems closely related, although
opposite.  Rather than copy working while paste fails, my problem (in 1.7b on
linux) is that copy is failing while paste works.  If I copy something in
another program, say emacs, I can paste it in Mozilla.  But any string I attempt
to copy in Mozilla (browser or email at least, text entry area or html text)
fails to be copied either by Ctrl-C, or using a right click and select Copy, or
by selecting the Edit/Copy menu item.  I can tell the copy failed because when I
paste, either in Mozilla or in another program, I get the prior copied string
rather than the one I just attempted to copy.  

However, select and drag-drop of a string in Mozilla *does* seem to copy/cut it
and paste it at the destination, though without actually affecting the clipboard
buffer.

I expect this is a temporary condition, such that after I kill this browser
process and restart, the problem will be gone for some time.... we'll see...

Comment 9

13 years ago
I had this on Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.2)
Gecko/20040811 Firefox/0.9.1+, even copying URL without "http://" prefix failes
until I re-create a new window.

Comment 10

13 years ago
(In reply to comment #9)
> I had this on Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.2)
> Gecko/20040811 Firefox/0.9.1+, even copying URL without "http://" prefix failes
> until I re-create a new window.

Happens in Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3)
Gecko/20041020 Firefox/1.0 too. When you move to another page in the same window
then go back, you can copy URLs again in the original page with the bug.
Product: Browser → Seamonkey

Comment 11

13 years ago
This occurs for me on XP.  

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Its uber-annoying, can you please fix it, or if its fixed, get a new RC out?

Comment 12

13 years ago
(In reply to comment #3)
> Reporter: please try this using a recent nightly build from
> <http://ftp.mozilla.org/pub/mozilla/nightly/latest/>. If it works, please
> resolve this bug as WFM. Thanks !

I have downloaded latest nightly builds. And nightly versions of firefox or
mozilla does NOT fix this. (I can't 100% reproduce but second time copy always
seems to fail after a dobbeltclick - but sometimes also first. The next copy
does nothing. The "paste" menuitems are not even becomming vissible within
firefox. So the copy URL rutine must have failed silent !

There is no problems with copying text from the pages I am on. 
It is only the URL-copy.

I have this problem on a Windows 2003 running on a Citrix Server.

At my home linux, and my local desktop this and home windows I have never seen
this problem on those machines.

It might be that Windows have a problem. I have a related problem in another
program yeilds the error like (cant reproduce right now) 'Cannot copy to
clipboard'  (It is SQL Navigator 4.3 - However it does copy the text anyway) 

It is VERY annoying since it you often want to paste URLs into mails.
It often helps to copy something from somewhere else to escape this problem and
then the copy wonks again.

Comment 13

13 years ago
Guess there are some type/language errors in the above ....
Always seems to fail after a dobbeltclick => on the URL-edit.

About the machines. (The above does not make sence at all)
On Home W2K, Home XP, Home Linux, Work XP I have no problem. 

I have only seen this problem on Windows 2003. (A Citrix server)

There are probably more errors in the above but with these corrections it should
be readable.

Try to focus on how it can happen that paste gets disabled after a URL copy.
Maybe I could look at this problem myself. Can I get a filename (& function)
hint from anybody or do I need to search it out myself ?

Comment 14

13 years ago
Happened in Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2)
Gecko/20050406 Firefox/1.0+

I copied a portion of URL without an http:// prefix to paste it in the URL bar,
but nothing happened when I actually chhose 'paste' in the context menu (yes
it's not grayed). Since it might be a focus issue, I set the mouse cursor in the
URL bar by clicking it and tried to move the caret by arrow keys, but strangely
it didn't move and disappeared when I pushed arrow keys.

Comment 15

13 years ago
> Maybe I could look at this problem myself. Can I get a filename (& function)
> hint from anybody or do I need to search it out myself ?

Hmmm don't think I will be able to fix this ... After 8 hours I still have NOT
compiled this beast (on windows). (And I am a linux-user) ..... 

But I can suply more information .... 
When (c:\windows\system32\clipbrd.exe) is running it is imposible to create this
problem .... (Can anybody else confirm this?). There is also no problem if
firefox is started from Visual stuio (as if you want to debug). 

Somehow firefox lags of doing something with the clipboard. This is not just a
problem with the URL but with the google-search upper right ...
(And any other edit-contorls I think...)

This might be a problem with the gtk edit control, but that is just a guess...

Comment 16

12 years ago
Also seen with:

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8) Gecko/20051215 SeaMonkey/1.0b

Copy silently fails. If I copy text from another app, the copy function resumes working in Seamonkey. Eg. I switch to Mulberry (my email client), "paint" and copy (control-C or RMB context menu) some text in an email message. (No paste required.) I can then successfully copy text from the Seamonkey URL entry field, or use Copy Link Location in the RMB context menu.

I originally observed this with Seamonkey 1.0 alpha, and got a fix from a nightly build:

http://groups.google.com/group/netscape.public.mozilla.seamonkey/browse_frm/thread/19505f12c49de413/

So this may be a regression.

I had the same issue trying to copy the above newsgroup link to paste and my workaround of copying in another app wasn't working. But clicking in the body of the tab with the newsgroup thread (as described in comment 2) allowed me to copy the link from the URL field.

Comment 17

12 years ago
This bug has affected every build of FireFox I have used since 1.0.3, and effectively renders the browser unusable. It has turned up in other downstream variants of the mozilla trunk (just tested "flock" with the same results), and is affecting many users. 

PLEASE promote this bug to "blocker" status. I do not believe that firefox 1.5 should have been released with this bug, or that it should remain beyond 1.5.0. 

Firefox will hemmorage users as they hit this bug and find their browser inoperable for anything but reading.
(In reply to comment #17)
> This bug has affected every build of FireFox I have used since 1.0.3 , and
> effectively renders the browser unusable. It has turned up in other downstream
> variants of the mozilla trunk

does it happen with a nightly?
see http://ftp.mozilla.org/pub/mozilla.org/seamonkey/nightly/latest-trunk/
and what are your steps to reproduce?

Comment 19

12 years ago
Okay, so after reading everything I could on this, I found some useful comments on Bug <a href="https://bugzilla.mozilla.org/show_bug.cgi?id=220900">bug 220900</a> (dupe?). 

My steps to recreate were:

start firefox (safemode, single tab) 
copy the URL from the url bar. 
Paste it. Copy again. Paste it. Copy again. Broken. 
rom then on, I could not copy or cut - it simply cleared the clipboard.

upon closing Remote Desktop Client aka mstsc (one of the workarounds suggested) I no longer experience this issue. It seems to be related to the way that mstsc keeps the local and remote clipboards in sync. What's strange is that I've never encountered this in a non-mozilla app. Is there some non-standard way that we're writing to the clipboard that doesn't handle a windows exception, or is terminal services client completely to blame?

Comment 20

12 years ago
I have experienced the same problem while also having a Remote Desktop session open.

Comment 21

12 years ago
This repros much better for me when I leave the firefox window very quickly after copying. In other words, ctrl+c and immediately switch to notepad, and the clipboard is empty.

If I hit ctrl+c and wait a couple seconds, then it will often work fine.

I am on XP Pro SP2.

Comment 22

12 years ago
.... this could mean that perhaps there's a long delay between ctrl+c and when the text is grabbed from the edit box.

So by the time firefox does GetWindowText(GetFocus()), the focus is in another application, and BLAM, it can't get the text from it. Whala, empty clipboard.

This would also explain the random behavior.

Hopefully a developer can validate this theory...

Updated

12 years ago
Assignee: general → jag
Component: General → XP Toolkit/Widgets
Product: Mozilla Application Suite → Core
QA Contact: general → jrgmorrison

Comment 23

12 years ago
Is this related to Bug 133439?

Comment 24

12 years ago
(In reply to comment #23)
> Is this related to Bug 133439?
> 

My problem seems to be related to that. 
Current nightly build seems not to have this the problem!

Comment 25

12 years ago
(In reply to comment #24)
> (In reply to comment #23)
> > Is this related to Bug 133439?
> > 
> 
> My problem seems to be related to that. 
> Current nightly build seems not to have this the problem!
> 

Yeah I've not seen this for a while. WFM

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060407 Firefox/3.0a1

 and

--> DUPE

*** This bug has been marked as a duplicate of 133439 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.