On SunOS claudia 5.6 Generic_105181-16 sun4u sparc SUNW,Ultra-5_10 It doesn't start..

VERIFIED DUPLICATE of bug 13202

Status

SeaMonkey
Build Config
P3
blocker
VERIFIED DUPLICATE of bug 13202
18 years ago
13 years ago

People

(Reporter: Carrer Yuri, Assigned: Jon Granrose)

Tracking

Trunk
Sun
Solaris

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
I'm running Solaris SunOS claudia 5.6 Generic_105181-16 sun4u sparc
SUNW,Ultra-5_10. From the M9, when I run ./mozilla (taken from the nightly
builts and olso from MXX releases), I have segmentation fault.
Here a truss trace:

munmap(0xEDB64000, 57344)                       = 0
mmap(0xEDB72000, 31840, PROT_READ|PROT_WRITE|PROT_EXEC, MAP_PRIVATE|MAP_FIXED,
12, 401408) = 0xEDB72000
open("/dev/zero", O_RDONLY)                     = 13
mmap(0xEDB7A000, 424, PROT_READ|PROT_WRITE|PROT_EXEC, MAP_PRIVATE|MAP_FIXED, 13,
0) = 0xEDB7A000
close(12)                                       = 0
mprotect(0xEDB00000, 406784, PROT_READ|PROT_WRITE|PROT_EXEC) = 0
mprotect(0xEDB00000, 406784, PROT_READ|PROT_EXEC) = 0
close(13)                                       = 0
munmap(0xEF1A0000, 8192)                        = 0
write(9, " -01\01002\0\0\b\0 3 5 k".., 72)      = 72
read(9, "0182\0 ,\0\002D7\0\0\001".., 32)       = 32
read(9, "\003\0\0\0\0\010\0  \0FF".., 28)       = 28
read(9, "\0\0\0 i\0\0\0 j\0\0\0 @".., 192)      = 192
read(9, "\0\0\001\004\001\0\0\0\0".., 2688)     = 2688
write(9, " -01\01202\0\0\t\0 9 5 k".., 80)      = 80
read(9, "0182\0 .\0\002D7FFFF\001".., 32)       = 32
read(9, "\002\0\0\0\0\010\0  \0FF".., 28)       = 28
read(9, "\0\0\0 i\0\0\0 j\0\0\0 @".., 192)      = 192
read(9, "\0\0\001\003\001\0\0\0\0".., 2688)     = 2688
open("/tmp/carrery/package/libgfx_gtk.so", O_RDONLY) = 12
fstat(12, 0xEFFFE39C)                           = 0
mmap(0x00000000, 8192, PROT_READ|PROT_EXEC, MAP_PRIVATE, 12, 0) = 0xEF1A0000
mmap(0x00000000, 1875968, PROT_READ|PROT_EXEC, MAP_PRIVATE, 12, 0) = 0xED900000
munmap(0xEDAB6000, 57344)                       = 0
mmap(0xEDAC4000, 20368, PROT_READ|PROT_WRITE|PROT_EXEC, MAP_PRIVATE|MAP_FIXED,
12, 1785856) = 0xEDAC4000
close(12)                                       = 0
mprotect(0xED900000, 1787640, PROT_READ|PROT_WRITE|PROT_EXEC) = 0
mprotect(0xED900000, 1787640, PROT_READ|PROT_EXEC) = 0
munmap(0xEF1A0000, 8192)                        = 0
    Incurred fault #6, FLTBOUNDS  %pc = 0xEDA74CC4
      siginfo: SIGSEGV SEGV_MAPERR addr=0x00000000
    Received signal #11, SIGSEGV [caught]
      siginfo: SIGSEGV SEGV_MAPERR addr=0x00000000
sigprocmask(SIG_SETMASK, 0xEF217CE8, 0x00000000) = 0
sigaction(SIGSEGV, 0xEFFFE730, 0x00000000)      = 0
setcontext(0xEFFFE8F0)
    Incurred fault #6, FLTBOUNDS  %pc = 0xEDA74CC4
      siginfo: SIGSEGV SEGV_MAPERR addr=0x00000000
    Received signal #11, SIGSEGV [default]
      siginfo: SIGSEGV SEGV_MAPERR addr=0x00000000
        *** process killed ***

 I would like to run it :)

Comment 1

18 years ago
This is likely a duplicate of bug 13202. Could you check the stack trace
in a debugger and see if it looks like:
#0  0xeda74cc4 in gdk_rgb_set_min_colors ()
#1  0xeda74cc0 in gdk_rgb_set_min_colors ()
#2  0xeda74e90 in gdk_rgb_init ()
#3  0xeda77f78 in gdk_rgb_get_visual ()

Updated

18 years ago
Assignee: leger → granrose
Component: Browser-General → Build Config
QA Contact: leger → granrose

Comment 2

18 years ago
Updating component.
(Assignee)

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
Target Milestone: M13
(Assignee)

Comment 3

18 years ago
I agree, resolving as duplicate.

Try the more recent builds, like the M12 and check the stack trace as mats
suggested above, and if it's different, go ahead and reopen this with the new
stack trace.

*** This bug has been marked as a duplicate of 13202 ***
(Assignee)

Updated

18 years ago
Status: RESOLVED → VERIFIED
(Assignee)

Comment 4

18 years ago
somehow I ended up as QA contact, so verifying duplicate as well.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.