Chatzilla and calendar window menu items shows up below the menu separator

VERIFIED FIXED in mozilla1.6final

Status

Other Applications
ChatZilla
VERIFIED FIXED
14 years ago
11 years ago

People

(Reporter: Sean Su, Assigned: Scott MacGregor)

Tracking

({polish})

Trunk
mozilla1.6final
x86
Windows XP
polish

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [cz-0.9.68])

Attachments

(4 attachments, 1 obsolete attachment)

23.50 KB, image/jpeg
Details
24.30 KB, image/jpeg
Details
676 bytes, patch
Mostafa Hosseini
: review+
(not reading, please use seth@sspitzer.org instead)
: superreview+
(not reading, please use seth@sspitzer.org instead)
: approval1.6+
Details | Diff | Splinter Review
906 bytes, patch
James Ross
: review+
Details | Diff | Splinter Review
(Reporter)

Description

14 years ago
depending on if chatzilla and/or calendar is installed, either chatzilla and/or
calendar menu item will show up below the menu seperator.

It looks like who ever is the last menu item will be shown below the menu seperator.

images of the problems coming up.
(Reporter)

Comment 1

14 years ago
Created attachment 124010 [details]
image of problem
(Reporter)

Comment 2

14 years ago
Created attachment 124011 [details]
image after fix
(Reporter)

Comment 3

14 years ago
Created attachment 124012 [details] [diff] [review]
patch v1.0

this patch seems to fix the problem, however, this has only been verified on
win32.	I'll try applying the patch on the other platforms to make sure they
still look okay.

Comment 4

14 years ago
updating typo in summary to make this findable... sorry for the spam
Summary: chatzilla and calendar window menu items show up below the menu sperator → chatzilla and calendar window menu items show up below the menu separator

Comment 5

14 years ago
*** Bug 207345 has been marked as a duplicate of this bug. ***

Comment 6

14 years ago
this looks to have caused by bug 205865. (i see most of the people here are on
the bug already... just making the connection permanent... sorry for the spam)
(Reporter)

Updated

14 years ago
Attachment #124012 - Flags: superreview?(sspitzer)
Attachment #124012 - Flags: review?(shliang)

Comment 7

14 years ago
*** Bug 207957 has been marked as a duplicate of this bug. ***

Comment 8

14 years ago
*** Bug 210770 has been marked as a duplicate of this bug. ***

Comment 9

14 years ago
*** Bug 211631 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 10

14 years ago
chatzilla seems fixed, but calendar is not.
Assignee: ssu → mscott
(Assignee)

Comment 11

14 years ago
*** Bug 227676 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 12

14 years ago
chatzilla seems fixed to me.
Target Milestone: --- → mozilla1.6final
(Assignee)

Comment 13

14 years ago
Created attachment 136955 [details] [diff] [review]
patch
Attachment #124012 - Attachment is obsolete: true
(Assignee)

Updated

14 years ago
Attachment #124012 - Flags: superreview?(sspitzer)
Attachment #124012 - Flags: review?(shliang)
(Assignee)

Updated

14 years ago
Status: NEW → ASSIGNED
Summary: chatzilla and calendar window menu items show up below the menu separator → calendar window menu item shows up below the menu separator
(Assignee)

Updated

14 years ago
Attachment #136955 - Flags: review?(mostafah)

Updated

14 years ago
Attachment #136955 - Flags: review?(mostafah) → review+

Comment 14

14 years ago
ChatZilla *isn't* fixed. I just installed 1.6b (Windows, custom install, no
MailNews or Spellcheck) and I get pretty much the same as attachment 124010 [details].

Updated

14 years ago
Blocks: 218324
Keywords: polish

Comment 15

14 years ago
re comment 14, that depends on fact that the patch isn't checked in. ;)

Comment 16

14 years ago
I'm pretty sure nothing's changed wrt Chatzilla, as CVS still have the same
insertafter="tasksMenuAddressBook" attribute it's always had. This is the
problem, it relies on Address Book being installed. Question is, what should it
use? Ordinal positioning is out, could we just list all the items that go above
it in bottom-to-top order?

Updating summary.
Summary: calendar window menu item shows up below the menu separator → Chatzilla and calendar window menu items shows up below the menu separator
(Assignee)

Comment 17

14 years ago
> it relies on Address Book being installed

ah, that's why it appeared fixed to me.
Comment on attachment 136955 [details] [diff] [review]
patch

sr/a=sspitzer for 1.6
Attachment #136955 - Flags: superreview+
Attachment #136955 - Flags: approval1.6+
the calendar side is fixed.

but james brings up a good point, which still needs to be addressed.

Checking in calendarOverlay.xul;
/cvsroot/mozilla/calendar/resources/content/calendarOverlay.xul,v  <--  calendar
Overlay.xul
new revision: 1.14; previous revision: 1.13
done

Comment 20

13 years ago
(In reply to comment #16)
> it relies on Address Book being installed.

Not in my case. I have the Address Book installed, yet Chatzilla is still listed
after a separator:

  Navigator
  Mail & Newsgroups
  Composer
  Address Book
  -- separator --
  IRC Chat

Prog.

Comment 21

13 years ago
(In reply to comment #20)
> (In reply to comment #16)
> > it relies on Address Book being installed.
> 
> Not in my case. I have the Address Book installed, yet Chatzilla is still listed
> after a separator:

See
http://lxr.mozilla.org/mozilla/source/extensions/irc/xul/content/chatzillaOverlay.xul#22
- if Calendar is still using that ID, and it's not appearing right after it, you
have a lovely XUL overlay bug on your hands. :)

Comment 22

13 years ago
Sorry for he spam: I meant if Address Book still has that ID.
Product: Core → Other Applications

Comment 23

13 years ago
Created attachment 170849 [details] [diff] [review]
Implement comment 16

Tested on a --disable-mailnews build.
Attachment #170849 - Flags: review?(silver)

Comment 24

13 years ago
Comment on attachment 170849 [details] [diff] [review]
Implement comment 16

>Index: chatzillaOverlay.xul
>+        insertafter="tasksMenuAddressBook,tasksMenuEditor,IMMenuItem,tasksMenuNavigator"/>

I thought there were 5 things above ChatZilla usually? Yeah, you missed out the
Mail&News item - is that missing for a reason?

Comment 25

13 years ago
CCing Neil as I don't think he got my comment about the patch.

Neil, see comment 24.

Comment 26

13 years ago
(In reply to comment #24)
>Yeah, you missed out the Mail&News item - is that missing for a reason?
The mailnews and addressbook items are not available separately.

Updated

13 years ago
Attachment #170849 - Flags: review?(silver) → review+

Comment 27

13 years ago
Fix checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Comment 28

12 years ago
v
Status: RESOLVED → VERIFIED

Updated

11 years ago
Whiteboard: [cz-0.9.68]
You need to log in before you can comment on or make changes to this bug.