Closed Bug 206874 Opened 17 years ago Closed 16 years ago

Javascript console: error being added in an infinite loop, causing a huge mem leak: 20 MB/minute

Categories

(Core Graveyard :: Error Console, defect)

x86
Windows XP
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 147015

People

(Reporter: steffen.wilberg, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030522
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030522

In Javascript console, the same error doesn't stop to be added again and again.
This eats up 20 MB ram per minute!

Reproducible: Always

Steps to Reproduce:
1. Open Javascript console.
2. Browse to http://www.royal-muenchen.de/ctrl.html.
Actual Results:  
The console is filled up at once. Watch the scrollbar getting smaller. If you
click Clear, it is filled up again and again. You have to close the page to stop
this. I watched the mem usage in windows task manager: From 22 MB to 42 MB in
one minute and counting.
The error is: ScrollerBaseRef is not defined, Source File:
http://www.royal-muenchen.de/filmb.html, Line: 34.

Expected Results:  
The error should only show up once in the js console. There should be no mem leak.

Of course this site is completely broken. I'll file a TechEvangelism bug as well.
But even a page like this must not cause such a huge mem leak.
TechEvangelism regarding this site is bug 206880.
This is still present.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030913
Firebird/0.6.1+
Status: UNCONFIRMED → NEW
Ever confirmed: true
JavaScript Console is probably the wrong component. Maybe it's DOM Level 0?
Assignee: hewitt → dom_bugs
Component: JavaScript Console → DOM Level 0
QA Contact: jrgmorrison → ashshbhatt
No, javascript console is _exactly_ the right component.  What does this have to
do with the DOM?  The dom notifies there is an error; the JS console should deal
with only showing it once.
Assignee: general → js-console
Component: DOM: Level 0 → JavaScript Console
QA Contact: ashshbhatt → jrgmorrison

*** This bug has been marked as a duplicate of 147015 ***
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
Product: Core → SeaMonkey
Product: SeaMonkey → Core Graveyard
You need to log in before you can comment on or make changes to this bug.