Hyperlink to the file is ignored, nothing is done.

RESOLVED DUPLICATE of bug 84128

Status

SeaMonkey
UI Design
RESOLVED DUPLICATE of bug 84128
15 years ago
9 years ago

People

(Reporter: Robert Sill, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030507
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030507

If I make hyperlink to the file in our local network which seems to be like:
<td width="28%" height="23"><a href="file://servername/shared_directory/start.bat"> 
              Launching application batch file</a></td>
so, Mozilla 1.4 Beta makes nothing, no error or warning appears, hyperlink is
ignored and I can't launch files. But Microsoft Internet Explorer and Opera 7.11
really offer to me options: Save to disk and Open file.
All mentioned browsers are used under WINDOWS XP HOME, but the situation is for
the Mozilla similar also under Red Hat Linux, might be also under other Linuxes
(or Linuces :-))) ).

Reproducible: Always

Steps to Reproduce:
1. Make any web page and include hyperlinks like
<td width="28%" height="23"><a href="file://servername/shared_directory/start.bat"> 
              Launching application batch file</a></td>
2.
3.

Actual Results:  
Nothing, hyperlink was ignored, no action, no message or warning.

Expected Results:  
To offer file to be saved to disk or to be opened (executed).

Comment 1

15 years ago
This is the default behavior, for security reasons.  There is a bug about making
the error message more visible, with various other commentary in the comments
that may be useful to read.

*** This bug has been marked as a duplicate of 84128 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Component: Browser-General → XP Apps: GUI Features
QA Contact: general → paw
Resolution: --- → DUPLICATE

Comment 2

15 years ago
I should add, that link would not work, even if it passes the security checks. 
Server links must be in the form "file:\\\\\hostname\resource" (with 5 slashes).
 This is mentioned in the release notes, and bug 66194.
Product: Core → Mozilla Application Suite

Updated

9 years ago
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.