When I enter nonbreaking spaces (ALT 255 or ALT 160) in forms, they get converted to normal spaces.

VERIFIED DUPLICATE of bug 194498

Status

()

VERIFIED DUPLICATE of bug 194498
16 years ago
12 years ago

People

(Reporter: Firebird.10.BobBlaylock, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6

  In various web-based message forums, I very often use non-breaking spaces,
whicgh I try by holding down the ALT key while typing “255” on the keypad.  From
any other browser, these get entered as nonbreaking spaces, and allow me to
format my message in ways that the combination of HTML and the forum code itself
otherwise suppresses.  In forums that allow HTML, I can usually accomplish the
same thing by typing an ampersand followed by “nbsp;”, but many forums either
don't allow HTML at all, or only allow selected parts of HTML that often don't
support this ampersand-nbsp; use.

  Other extended characters that I type via the ALT key get treated correctly
under Phoenix/Fireird, but the nonbreaking space does not.  It always gets
submitted as a normal space.

Reproducible: Always

Steps to Reproduce:
1.  Go to any web-based message board.
2.  Try entering a message in which you indent the first line of a pragraph
using two nonbreaking spaces.  Type each nonbreaking space by holding dwn the
ALT key while typing “255” or “160” on the numeric keypad.
3.  Post or preview that message, and not ethat the first line is NOT indented
as you meant it to be.
4.  Repeat the process using Netscape, or probably just about any other
browser.  See the difference?

Actual Results:  
  Every paragraph that I've typed in this form, I've started with two
nonbreaking spaces, to indent the first line.  Every period at the end of a
sentence, I've followed with one nonbreaking space, and one normal space.  I'm
sure that in examining the text that I've entered, you'll find no nonbreakling
spaces, that they have all been converted to normal spaces.

Expected Results:  
  It should never convert nonbreaing spaces to normal spaces; it should pass
them on unmolested, as it does with otehr extended characters.

*** This bug has been marked as a duplicate of 194498 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
VERIFIED
Status: RESOLVED → VERIFIED
Duplicate of this bug: 374774
You need to log in before you can comment on or make changes to this bug.