Closed Bug 206936 Opened 20 years ago Closed 19 years ago

New windows opened from external applicaton (Entourage) have wrong theme

Categories

(Firefox :: General, defect, P1)

PowerPC
macOS
defect

Tracking

()

VERIFIED FIXED
Firebird0.7.1

People

(Reporter: mozilla.org, Assigned: bugs)

References

()

Details

(Keywords: qawanted)

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6

I have the default Firebird theme, except I have customized the toolbar to show
only big icons (no text). I have also installed the SmoothWheel v0.2 Extension.

I have made Firebird my default browser using the Web tab in the OS X Internet
preferences pane.

When I click on a link in Entourage V.X it opens a new Firebird window but it
uses the Classic theme rather than the default one (Modern?). Also it sometimes
shows the Siebar.

Reproducible: Always

Steps to Reproduce:
1. Set Firebird as your default browser in OS X Internet Preferences Pany
2. Open Firebird
3. Open Entourage
4. Find an email with a link (In my case it is a plain-text email, not HTML)
5. Click the link

Actual Results:  
New firebird window will open with Classic theme...

Expected Results:  
Should have opened a window with the Modern theme. (Ideally it should have
reused an existing window, but that's a different issue. ;) )
-> Phoenix
.
Assignee: shliang → blaker
Component: Themes → General
Product: Browser → Phoenix
QA Contact: pmac → asa
Version: Trunk → unspecified
- Also, some features of this new window are quite different: for example it
uses a completely different Preferences dialog (the default Mozilla Preferences
dialog?).

- This doesn't depend on the application that opens the new window: all you need
is specify Mozilla Firebird as the "System Preferences > Internet > Web >
Default Web Broswer"
> (Ideally it should have reused an existing window, but that's a different
issue. ;)

Open "about:config" and set "borowser.always_reuse_window" to "true". Yet, this
is   just a workaround, I'd really like to see this bug fixed.
i'm seeing this too.  it's actually a classic theme seamonkey window, complete
with seamonkey sidebars and everything.  it's really quite amazing, actually.  i
would have thought that firebird would have removed all vestiges of the classic
theme by now.  please mark this bug as confirmed.  be nice if the summary had
classic in it somewhere, i almost filed a dup.
This sounds like a dupe of bug #204418 - resolving accordingly...

*** This bug has been marked as a duplicate of 204418 ***
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
mind explaining why?  sounds like a completely different bug to me...
Yeap, you're right! I was sure we already had a bug filed because of this but I
obviously catched the wrong one...
=> I'll re-open the bug so we can have a further search for possible dupes...
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Keywords: qawanted
*** Bug 209478 has been marked as a duplicate of this bug. ***
*** Bug 210957 has been marked as a duplicate of this bug. ***
*** Bug 211555 has been marked as a duplicate of this bug. ***
#4: Imho recycling windows is the wrong thing because the windows usually do
contain something useful. If they did not, they would be probably closed. And it
is not easy to tell (without using a debugger) which window is going to be recycled.
#4 & #12: I sorry I even mentioned the new/recycled window thing  here... 

Like I said originally the it is completely seperate from THIS bug related to
new windows opening with the wrong theme.

I suspect it also has something to the Mac specific fact that a program will
continue running even if it has no windows open. On Windows and others that will
quit the program.

It seems like there is enough info here to declare this Confirmed and to get it
assigned to someone to fix. Who has the authority to ge this bug moved beyond
the NEW status?
new is equivalent to confirmed.  status won't change until fixed.  and it seems
that it is assigned to blake.  i wouldn't expect it to be fixed soon though,
none of the long-standing mac firebird bugs have been fixed, and with the
mozilla foundation shakeup...
*** Bug 213093 has been marked as a duplicate of this bug. ***
reassigning mac bugs, sorry for the spam.
Assignee: blake → nobody
--> hyatt

do we even still have these UI bits?  if we do, we should clean that up
Assignee: nobody → hyatt
QA Contact: asa → mpconnor
*** Bug 215740 has been marked as a duplicate of this bug. ***
*** Bug 216032 has been marked as a duplicate of this bug. ***
ugh, something about launching links in firebird is pretty broken.  see my
comment in bug 210553.  as for this particular bug (seamonkey windows
appearing), it is now WFM in smartasfuck.com build 20030821.
*** Bug 219382 has been marked as a duplicate of this bug. ***
*** Bug 220686 has been marked as a duplicate of this bug. ***
how is Bug 220686 a duplicate???

i get an XML Parsing Error: undefined entity

i don't get a window opening up with a different theme.

is there a fix for this?
*** Bug 220199 has been marked as a duplicate of this bug. ***
the old UI was in chrome://navigator/content/navigator.xul, if that UI is broken
by an extension, you might get a parsing error, but if you're getting that
error, its a sign that its loading the wrong UI.  Because something broke that
UI doesn't mean its a separate bug.  (If it is, its INVALID since navigator.xul
is long since deprecated :)
hey, has anyone seen this in a while?  (i haven't.)  i am seeing what's
described in bug 210553.  wondering if this bug should be merged into that one.
In response to Comment #29 I downloaded the smartasfuck.com build 20031004.

In this build it no longer opens a browser window with the Mozilla look and
instead displays the XML Parsing error.

But this seems like a step backwards... At least before the correct Web page was
displayed.

In any case, I too think it would be a good idea to merget this with bug 
210553. (Or vice versa since this bug came first...)

I just downloaded Firebird 0.7 for OSX, and am running into this bug.  When I
try to launch a URL from NetNewsWire or LaunchBar I get the error:

XML Parsing Error: undefined entity
Location: chrome://navigator/content/navigator.xul
Line number 46, Column 1

<window id="main-window

I've never used FireBird on this machine, so this shouldn't be a conflict caused
by a previous install.  I've installed no plugins or extensions, this is exactly
as I downloaded it.  And it is a total show stopper from using the browser on OS
X.  Thanks.
I'm seeing what comment #28 is seeing, too. Also, if you close all of the
windows Firebird has open, and then open a new window, Firebird stops using the
address bar. I don't know if this is the same bug, or a related one.
comment 28, comment 29, you're refering to bug 210553.  comment 29, you're also
refering to bug 220454.
-> me, 0.7.1
Status: NEW → ASSIGNED
Priority: -- → P1
Target Milestone: --- → Firebird0.7.1
-> me, 0.7.1
Assignee: hyatt → bugs
Status: ASSIGNED → NEW
Fixed. 
Status: NEW → RESOLVED
Closed: 19 years ago19 years ago
Resolution: --- → FIXED
No errors now, but external apps now open new windows, not new tabs.  Prefs don't show where 
new windows open as tabs....
re comment 34, that is not part of this bug.  UI and stable functionality for
how to handle external links is planned but not implemented yet.  The Tabbrowser
Extension does include this, but your mileage may vary regarding stability.
verified fixed 2003-11-09
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.