Closed Bug 207038 Opened 19 years ago Closed 19 years ago

Putting Mail on an FAT32 Partition results in rebuilding summary files

Categories

(MailNews Core :: Database, defect)

x86
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: Ch.Ehrlicher, Assigned: Bienvenu)

References

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.3) Gecko/20030312

My mailfolder is on a Fat32-partition so that I have access to my mails in linux
and windows. But now everytime I start mozilla the summary files are rebuild.
After that all my changes (labels and sort-order) are gone. To test I've put my
mail-folder to a linux partition - all works fine but now I can't access them
when I'm under windows. 

Reproducible: Always

Steps to Reproduce:
1. Put the mail-folder to a Fat32-partition and symlink the folder
2. Start mozilla
3. Change a label or the sort-order
4. Restart mozilla


Actual Results:  
The summary files are rebuild and all changes are lost.

Expected Results:  
No rebuild of the summary files / rebuild without loosing the changes

It looks like a synchronisation problem of the filetimes between Fat32 and Linux-fs.
Dupeing to bug 178641, where most of the 'rebuilding' bugs seem to be duped
against. Note that Mozilla 1.4b is already a lot faster in rebuilding, so you'll
notice it less often.

*** This bug has been marked as a duplicate of 178641 ***
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
Bug 178641 is closed and there it is said, that it is fixed in 1.2 - but I use
1.3 so I think when it is a dupe than the bug 178641 should be reopended at least...

I reopen it 'cause it isn't fixed for me.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
worksforme with linux trunk 20030526 and 1.3

can you try this with a clean profile?
Note that an ext2 fs records modification times to the nearest second 
while FAT fs's only save times to the nearest two seconds. Lots of goofy 
things can happen because of this.
yes, that will definitely cause problems. The workaround is to use the timestamp
leeway code I put in another bug, which will allow you to set a currently hidden
preference that makes the code tolerant of slightly off timestamps. I'll work on
getting that checked in and let you know.
Status: UNCONFIRMED → NEW
Ever confirmed: true
this patch implements a pref, "mail.db_timestamp_leeway", that can be set to a
small number of seconds to allow for file systems with changing file stamps. It
has an unrelated change for a pref for threading by subject without re, which
isn't turned on. this has r/sr=sspitzer.
you can try this pref - if it works, we can consider adding a UI for it.
Sorry, but I can't compile mozilla by myself. Is this patch maybe in 1.4RC1?
this was checked into the trunk, so all you need to do to try it is download a
1.5 trunk build and set the pref in your prefs.js - I don't think I this made it
into 1.4
any luck trying this?
Sorry for the delay.
All works fine with the latest build. I've set mail.db_timestamp_leeway to 5
seconds.
Marking fixed. I'll file a bug about exposing this pref in the UI.
Status: NEW → RESOLVED
Closed: 19 years ago19 years ago
Resolution: --- → FIXED
*** Bug 212938 has been marked as a duplicate of this bug. ***
After a (very) clean reinstall I noticed, that I can't set this value in
about:config because it isn't showed. I have to manually set it by entering the
values in prefs.js. I thought this should be done (like mentioned in comment 12)
Product: MailNews → Core
Relates to bug 286572 and 266837. Could anyone confirm?
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.