Empty result when there's negative time in "Hours Left" field

RESOLVED WORKSFORME

Status

()

Bugzilla
Creating/Changing Bugs
RESOLVED WORKSFORME
15 years ago
5 years ago

People

(Reporter: Harri Vartiainen, Assigned: Jeff Hedlund)

Tracking

2.17.4
x86
Windows XP

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; MSIE 5.5; Windows NT 5.1) Opera 7.01  [en]
Build Identifier: 

When setting the "Hours left" to negative value, eg. -1.0 (JavaScript does 
this), bugzilla sends back an empty result page.




Following error message is in Apache's error log:


[Sun May 25 16:42:53 2003] [error] [client x.y.z.w] Can't use string ("field") 
as a HASH ref while "strict refs" in


 use at Bugzilla/Error.pm line 35., referer: 
http://xxxxxx/bugzilla/show_bug.cgi?id=297






Reproducible: Always

Steps to Reproduce:
1. Set hours left to "-1.0"


2. Commit


3.



Actual Results:  
Empty page


Expected Results:  
Error message about negative value.
(Reporter)

Updated

15 years ago
Version: unspecified → 2.17.4

Comment 1

15 years ago
I see this too on our installation of Bugzilla 2.17.4 ... confirming
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

14 years ago
Seen on landfill.
(Assignee)

Comment 3

14 years ago
I just tested this on landfill and my local installation (running 2.17.6), and I
get the appropriate error every time.

Is this now a WFM?
Assignee: myk → jeff.hedlund
(Assignee)

Comment 4

14 years ago
*** Bug 214716 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 5

14 years ago
(In reply to comment #3)
> I just tested this on landfill and my local installation (running 2.17.6), and I
> get the appropriate error every time.
> 
> Is this now a WFM?

 Tested also with 2.17.6, works for me.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.