Half-width characters corrupt full-width Japanese characters in edit boxes, bookmark titles, tab titles.

VERIFIED INVALID

Status

()

Core
Internationalization
VERIFIED INVALID
15 years ago
15 years ago

People

(Reporter: junkmailnotread, Assigned: smontagu)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030522
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030522

Inserting half-width (e.g. ASCII) characters in front of full-width Japanese
characters in edit boxes corrupts the Japanese characters. Removing the
half-width characters corrects the problem.

Reproducible: Always

Steps to Reproduce:
1. Go to URL provided (www.google.co.jp with search string)
2. See that the Japanese characters in the search string edit box are corrupt.
3. Delete the leading 'x' character from the search string edit box.
4. See that the Japanese characters are now OK.
Actual Results:  
The Japanese characters are corrupted whenever half-with characters are inserted
at the beginning of the edit box. When the half-width characters are removed,
the problem goes away.

Expected Results:  
Japanese characters should be displayed in edit boxes consistently, regardless
of whether there are half-width characters at the beginning of the line.

The same problem exists with bookmark titles and tab titles.

Inserting half-width characters between Japanese characters doesn't seem to
cause the problem. It's only when the half-width characters are at the beginning
of the line.

Mozilla 1.3 was built from source using the Gentoo Linux package manager "emerge".

The Gentoo Linux package is mozilla-1.3-r1, which uses (among others) the
fontconfig-2.2.0-r2 package. fontconfig has caused other problems with Japanese
fonts, so I wouldn't be surprised if that was implicated.

The Japanese font used is the Kochi Mincho TrueType font (kochi-mincho.ttf) from
http://www.on.cs.keio.ac.jp/~yasu/linux/fonts/

Comment 1

15 years ago
It works for me with 05-27 trunk build on linux RH8.0 with system default
Japanese font.

It also works for me by using the Kochi Mincho TrueType font (kochi-mincho.ttf),
I downloaded the font from:
http://www.on.cs.keio.ac.jp/~yasu/linux/fonts/kochi-mincho-0.2.20020727.tar.bz2
(Reporter)

Comment 2

15 years ago
I tried mozilla-i686-pc-linux-gnu-1.3.1.tar.gz from mozilla.org and (of course!)
it worked OK, though the fonts looked different.

My Gentoo Linux build of Mozilla handles fonts differently, using libXft.so.2.0,
libfontconfig.so.1.0.4 and libfreetype.so.6.3.3 among others. So it must be one
of those which has messed things up, rather than Mozilla itself.

So I'll report this to the Gentoo Linux people and hopefully they can progress
it at their end.

Sorry for the inconvenience. And thank you.
(Reporter)

Comment 3

15 years ago
I found the problem. It turns out that Gentoo's xfree-4.3.0-r2 package provides
its own version of libXft in /usr/X11R6/lib, while Mozilla was picking up an old
version in /usr/lib. Removing the old libXft fixed the problem. Kochi Mincho
doesn't look as good now, but that's another issue.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID

Comment 4

15 years ago
Mark as verified per previous comment.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.