[BLOCKER][dogfood][crash]opening 3 pane mail window causes crash

VERIFIED FIXED

Status

SeaMonkey
MailNews: Message Display
P3
blocker
VERIFIED FIXED
18 years ago
13 years ago

People

(Reporter: Kathleen Brade, Assigned: travis)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
With debug build from this morning on Mac, opening 3 pane mail window crashes.

Reproduce:
 * go to Tasks menu
 * pick Mail

Crash in nsJSUtils::nsConvertObjectToJSVal trying to QueryInterface aSupports
This is called from GetWindowCollectionProperty

rhp: I don't see any bug you may have filed... please dup this if I missed it!
(Reporter)

Comment 1

18 years ago
change product/component
Component: XPApps → Front End
Product: Browser → MailNews
(Reporter)

Updated

18 years ago
Assignee: don → phil

Comment 2

18 years ago
cc'ing lchiang

Updated

18 years ago
Assignee: phil → alecf

Comment 3

18 years ago
Alec's the sheriff today. Kathy, could you paste in the stack trace?

Comment 4

18 years ago
argh, my mac has locked up on me three times just trying to install today's
commercial build.... still working on it.

Comment 5

18 years ago
ok, I've got one stack trace deep in the bowels of javascript and the DOM. I'll
post a stack trace in a minute.

Comment 6

18 years ago
This LOOKS like DOM related stuff..



 Calling chain using A6/R1 links

  Back chain  ISA  Caller4

  00000000    PPC  20CBF9D4

  10B5BC40    PPC  20CBCB8C  main+00114

  10B5BBC0    PPC  20CBC65C  main1(int, char**)+005D0

  10B5BAD0    PPC  1FE36D50  nsAppShellService::Run()+00018

  10B5BA90    PPC  1FE05FE0  nsAppShell::Run()+00038

  10B5BA10    PPC  1FE06728  nsMacMessagePump::DoMessagePump()+0003C

  10B5B9C0    PPC  1FE069FC  nsMacMessagePump::DispatchEvent(int, EventRecord*)+

00174

  10B5B970    PPC  20A45874  Repeater::DoRepeaters(const EventRecord&)+00030

  10B5B930    PPC  1FDE8D10  nsMacNSPREventQueueHandler::RepeatAction(const

EventRecord&)+000

20

  10B5B8F0    PPC  20B3FD98  nsEventQueueServiceImpl::ProcessEvents()+00064

  10B5B8B0    PPC  20B53274  nsEventQueueImpl::ProcessPendingEvents()+00018

  10B5B870    PPC  20C410AC  PL_ProcessPendingEvents+0007C

  10B5B820    PPC  20C41148  PL_HandleEvent+00028

  10B5B7E0    PPC  20167CCC  nsStreamListenerEvent::HandlePLEvent(PLEvent*)+67CCC

  10B5B790    PPC  20168B58  nsOnStopRequestEvent::HandleEvent()+68B58

  10B5B740    PPC  2017FB74  nsInputStreamChannel::OnStopRequest(nsIChannel*,

nsISupports*, u

nsigned int, const unsigned short*)+7FB74

  10B5B6E0    PPC  2017DF08  nsLoadGroup::RemoveChannel(nsIChannel*, nsISupports*

, unsigned i

nt, const unsigned short*)+7DF08

  10B5B680    PPC  20BB9A34  nsDocLoaderImpl::OnStopRequest(nsIChannel*,

nsISupports*, unsign

ed int, const unsigned short*)+00064

  10B5B630    PPC  20BB9CEC  nsDocLoaderImpl::DocLoaderIsEmpty(unsigned int)+

0009C

  10B5B5E0    PPC  20BB9CD4  nsDocLoaderImpl::DocLoaderIsEmpty(unsigned int)+

00084

  10B5B590    PPC  20BBA060

nsDocLoaderImpl::FireOnEndDocumentLoad(nsDocLoaderImpl*, nsIChan

nel*, unsigned int)+00064

  10B5B540    PPC  20BCB1E8  nsWebShell::OnEndDocumentLoad(nsIDocumentLoader*,

nsIChannel*, u

nsigned int, nsIDocumentLoaderObserver*)+00134

  10B5B220    PPC  20A6DFAC  GlobalWindowImpl::HandleDOMEvent(nsIPresContext*,

nsEvent*, nsID

OMEvent**, unsigned int, nsEventStatus*)+000B4

  10B5B1C0    PPC  2052E0E0  nsEventListenerManager::HandleEvent(nsIPresContext*,

nsEvent*, n

sIDOMEvent**, unsigned int, nsEventStatus*)+2E0E0

  10B5B070    PPC  2052D0B0

nsEventListenerManager::HandleEventSubType(nsListenerStruct*, ns

IDOMEvent*, unsigned int)+2D0B0

  10B5ADF0    PPC  20ABAC04  nsJSEventListener::HandleEvent(nsIDOMEvent*)+001FC

  10B5ACD0    PPC  20A54DE0  nsJSContext::CallFunction(void*, void*, unsigned

int, void*, int

*)+001B0

  10B5AC10    PPC  20BE4040  JS_CallFunction+00018

  10B5ABD0    PPC  20BFC584  js_InternalCall+000B8

  10B5AB20    PPC  20BFC35C  js_Invoke+00554

  10B5AA40    PPC  20C02580  js_Interpret+05978

  10B5A810    PPC  20BFC35C  js_Invoke+00554

  10B5A730    PPC  20C02580  js_Interpret+05978

  10B5A500    PPC  20BFC35C  js_Invoke+00554

  10B5A420    PPC  20C0208C  js_Interpret+05484

  10B5A1F0    PPC  20C0B768  js_GetProperty+00160

  10B5A170    PPC  20AC0230  GetWindowCollectionProperty(JSContext*, JSObject*,

long, long*)+

002C4

Comment 7

18 years ago
adding danm  (window stuff) and vidur (DOM stuff)

Comment 8

18 years ago
*** Bug 20722 has been marked as a duplicate of this bug. ***

Comment 9

18 years ago
Latest info from bug 20722 is that this happens on all platforms
(Reporter)

Comment 10

18 years ago
*** Bug 20722 has been marked as a duplicate of this bug. ***

Updated

18 years ago
Severity: normal → blocker
OS: Mac System 8.5 → All
QA Contact: paulmac → lchiang
Hardware: Macintosh → All
Summary: [dogfood][crash]opening 3 pane mail window causes crash → [BLOCKER][dogfood][crash]opening 3 pane mail window causes crash

Comment 11

18 years ago
This is happening on all 3 platforms in today's release builds.  Just even start
with ./mozilla -mail.  Raising to blocker.
Just a little bit more stack trace info (MAC)

...
   07626848                PPC   1750FAD4 js_IsScopeLocked+00010
   07626828    07626820    PPC   173709E8 GetWindowCollectionProperty(JSContext*, JSObject*, long, long*)+
00394
   07626808                68K   06DDC97E
   07626800                68K   0762683E
   076267E8    076267E0    PPC   1747258C nsString::Assign(const unsigned short*, int)+00044
   076267E0    076267DC    68K   0762681E
   076267D8    076267D0    PPC   173A0648 nsDOMWindowList::NamedItem(const nsString&, nsIDOMWindow**)+
000FC
   076267D0    076267CC    68K   0762681E
FYI: I have a Windows build from last night around 10 pm which works well.

Comment 14

18 years ago
turns out this is 20722 and 20707 as well

Comment 15

18 years ago
oops, getting my bugs confused.
Anyway, I'm looking over the checkins last night to see if I can see anything
Good news, since I pull & build mozilla/dom after Tfavis checkin some fixes, I don't crash anymore when opening
Messenger.
Forget to say that was on Mac.

Comment 18

18 years ago
oh cool, I'll check those out on linux too (my build is almost done)

Updated

18 years ago
Assignee: alecf → travis

Comment 19

18 years ago
I'm going to reassign to travis right now, since he probably fixed the problem

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 20

18 years ago
ok, more confirmation from beard, and I can start mail on linux as well. marking
fixed.
(Reporter)

Updated

18 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 21

18 years ago
verifying; this works for me too :-)
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.