Closed Bug 207076 Opened 17 years ago Closed 17 years ago

"What should Mozilla do with this file?" dialog doesn't remember preference.

Categories

(Core Graveyard :: File Handling, defect, major)

x86
Windows 2000
defect
Not set
major

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 184971

People

(Reporter: crumbinator, Assigned: law)

References

()

Details

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030507
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030507

When trying to open a file via a link on a web page, said dialog pops up.  After
accepting my preference and opening the file, if I open a file of the same type,
the window still appears.  This behaviour occurs even if I uncheck "Always show
this dialog before handling files of this type".

Very annoying.

Reproducible: Always

Steps to Reproduce:
1. Go to soma.fm.
2. Try to open a playlist file link.
3. Select "Open it with the default application" (winamp in my case)
4. Uncheck "Always show this dialog before handling files of this type"
5. Repeat from step one.  Ad infinitum.  Until it is fixed, anyway.

Actual Results:  
The steps went exactly as described.

Expected Results:  
Mozilla should have saved my preference from this dialog and not asked me again.
I thought Mozilla might not save such a preference when using the default
profile, so I created a new one.  

No change.  Same problem.
Severity: normal → major
Confirming 2003052909 trunk xp
Status: UNCONFIRMED → NEW
Ever confirmed: true
this works for me with "Groove salad" and "secret agent". are you using another
playlist?

Also, would it be possible for you to attach the file mimeTypes.rdf to this bug
(using http://bugzilla.mozilla.org/attachment.cgi?bugid=207076&action=enter)?
You can find that file in your profile, see
http://www.mozilla.org/releases/mozilla1.4/installation.html#files_profiles for
the location
The problem persists in:

  Mozilla 1.4 Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4)
Gecko/20030624

Any playlist I encounter anywhere does produce the same results.  I have 
attached the requested file.

Thanks.
sorry for replying so late :(

Thanks for attaching the file, Tony - it shows that Mozilla thinks that the
mimetype is "audio/scpls", while it really is "audio/x-scpls"; so your setting
is saved under the former mimetype but looked up with the latter.

This is a known problem, and was fixed today, nightly builds from tomorrow or
later and 1.5beta or later should have this fixed.

*** This bug has been marked as a duplicate of 184971 ***
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.