Status

MailNews Core
Networking: POP
RESOLVED WORKSFORME
15 years ago
9 years ago

People

(Reporter: Patrick Villa, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (compatible; Konqueror/3.1; Linux)
Build Identifier: Mozilla 1.3

Hello, 
 
First, I apologyse  for my poor english and thank  you so 
much for the work done : Mozilla is a very good 
navigator/mailer. For me better than IE 6. 
 
 Nevertheless, I  had found a problem/bug  in 
it. 
 
I  got the last version of mozilla with mandrake 9.1. I use a winmodem 
with PPP and  it works fine. 
 
If I click on "recept new mail" and if my connexion is running,  
everything runs well : my messages (arrive) are loaded. 
 
If I click on "recept new mail" and if my connexion isn't running, Mozilla 
prompts me : "can't resolving host xxx". OK, this is normal.  
However, it continue to try to resolving my host. Then, if I connect 
me to my IAP and click again on "Recept new 
mail", it continue to "resolving host xxx" and can't recept my mail. 
I must quit mozilla and re-open  
 
Yours 

Reproducible: Always

Steps to Reproduce:
1. Try to receive message with pop without PPP connexion 
2. Wait for error (normal) 
3. Connect 
4. Try to receive message. 
Actual Results:  
I can't connect on my pop server.  

Expected Results:  
The connexion

Comment 1

15 years ago
This is because Mozilla remembers every DNS-lookup forever, and doesn't respect
the TTL (time-to-live) of the DNS-record (even for a negative result).

Possibly a dupe of bug 162871. See also bug 168566 and bug 174590.

Workaround: click on the 'connection' icon on the lower right of every window to
go offline. Click again to go back online. Mozilla will now have cleared its
DNS-cache.

Comment 2

14 years ago
This bug is probably a duplicate of one of those fixed bugs. Please reopen if
you can still reproduce with a current build.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.