Compile error on nsDocAccessible in slackware 9.0

RESOLVED FIXED

Status

()

--
blocker
RESOLVED FIXED
16 years ago
15 years ago

People

(Reporter: mifrai, Assigned: aaronlev)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030401
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030401

...

gmake[4]: Leaving directory `/jochu/src/mozilla/ac
cessible/src/atk'
gmake[4]: Entering directory `/jochu/src/mozilla/a
ccessible/src/base'
nsDocAccessible.cpp
c++ -o nsDocAccessible.o -c -DOSTYPE=\"Linux2.4\"
-DOSARCH=\"Linux\" -I. -I./../html -I./../xul -I./
../../../layout/html/base/src  -I./../atk  -I../..
/../dist/include/content -I../../../dist/include/d
ocshell -I../../../dist/include/dom -I../../../dis
t/include/editor -I../../../dist/include/gfx -I../
../../dist/include/htmlparser -I../../../dist/incl
ude/intl -I../../../dist/include/layout -I../../..
/dist/include/locale -I../../../dist/include/necko
 -I../../../dist/include/plugin -I../../../dist/in
clude/pref -I../../../dist/include/string -I../../
../dist/include/uriloader -I../../../dist/include/
view -I../../../dist/include/webshell -I../../../d
ist/include/widget -I../../../dist/include/xpcom -
I../../../dist/include/xuldoc -I../../../dist/incl
ude/accessibility -I../../../dist/include -I/jochu
/src/mozilla/dist/include/nspr         -fPIC   -fn
o-rtti -fno-exceptions -Wall -Wconversion -Wpointe
r-arith -Wcast-align -Woverloaded-virtual -Wsynth
-Wno-ctor-dtor-privacy -pedantic -Wno-long-long -f
short-wchar -pthread -pipe  -DDEBUG -D_DEBUG -DDEB
UG_root -DTRACING -g -fno-inline -O   -DMOZILLA_CL
IENT -include ../../../mozilla-config.h -Wp,-MD,.d
eps/nsDocAccessible.pp nsDocAccessible.cpp
nsDocAccessible.cpp: In constructor
   `nsDocAccessible::nsDocAccessible(nsIDOMNode*,
nsIWeakReference*)':
nsDocAccessible.cpp:99: cannot pass objects of non
-POD type `class
   nsCOMPtr<nsIWeakReference>' through `...'



Reproducible: Always

Steps to Reproduce:

./configure --prefix=/usr --enable-default-toolkit=gtk2 --enable-optimize
--enable-xft --with-system-zlib --enable-crypto

make
Actual Results:  
...

gmake[4]: Leaving directory `/jochu/src/mozilla/ac
cessible/src/atk'
gmake[4]: Entering directory `/jochu/src/mozilla/a
ccessible/src/base'
nsDocAccessible.cpp
c++ -o nsDocAccessible.o -c -DOSTYPE=\"Linux2.4\"
-DOSARCH=\"Linux\" -I. -I./../html -I./../xul -I./
../../../layout/html/base/src  -I./../atk  -I../..
/../dist/include/content -I../../../dist/include/d
ocshell -I../../../dist/include/dom -I../../../dis
t/include/editor -I../../../dist/include/gfx -I../
../../dist/include/htmlparser -I../../../dist/incl
ude/intl -I../../../dist/include/layout -I../../..
/dist/include/locale -I../../../dist/include/necko
 -I../../../dist/include/plugin -I../../../dist/in
clude/pref -I../../../dist/include/string -I../../
../dist/include/uriloader -I../../../dist/include/
view -I../../../dist/include/webshell -I../../../d
ist/include/widget -I../../../dist/include/xpcom -
I../../../dist/include/xuldoc -I../../../dist/incl
ude/accessibility -I../../../dist/include -I/jochu
/src/mozilla/dist/include/nspr         -fPIC   -fn
o-rtti -fno-exceptions -Wall -Wconversion -Wpointe
r-arith -Wcast-align -Woverloaded-virtual -Wsynth
-Wno-ctor-dtor-privacy -pedantic -Wno-long-long -f
short-wchar -pthread -pipe  -DDEBUG -D_DEBUG -DDEB
UG_root -DTRACING -g -fno-inline -O   -DMOZILLA_CL
IENT -include ../../../mozilla-config.h -Wp,-MD,.d
eps/nsDocAccessible.pp nsDocAccessible.cpp
nsDocAccessible.cpp: In constructor
   `nsDocAccessible::nsDocAccessible(nsIDOMNode*,
nsIWeakReference*)':
nsDocAccessible.cpp:99: cannot pass objects of non
-POD type `class
   nsCOMPtr<nsIWeakReference>' through `...'



Expected Results:  
:P Compile right! *cry*

Comment 1

16 years ago
wfm... are you compiling current trunk or 1.3?

you might want to make sure your tree is up-to-date... make -f client.mk checkout?

Comment 2

16 years ago
what version of gcc are you using?

Comment 3

16 years ago
Using a linux slackware 9.0 (with gcc 3.2), compiling of mozilla 1.3.1 source
(with option used by reporter), building goes to its end.

Maybe reporter is using a younger source ?
(Reporter)

Comment 4

16 years ago
Oops. I never set the version on this report. I'm sorry. It's version 1.4b, not
trunk. 
Version: Trunk → 1.0 Branch

Comment 5

16 years ago
1.4b is the latest official trunk build available ;-)

Even if now, trunk is open for 1.5alpha development.
Version: 1.0 Branch → Trunk
-> accessibility
Assignee: mozbugs-build → aaronl
Component: Build Config → Accessibility APIs
QA Contact: granrose → dsirnapalli
It looks like you need |.get()|.
(Assignee)

Comment 8

16 years ago
Where do I need .get()?
Line 99 is where you're getting the error? Here is where my line 99 is.

  nsCOMPtr<nsIPresShell> shell(do_QueryReferent(mWeakShell));
  if (shell) {
    shell->GetDocument(getter_AddRefs(mDocument));
    nsCOMPtr<nsIViewManager> vm;
    shell->GetViewManager(getter_AddRefs(vm));    // <-- Line 99
    nsCOMPtr<nsIWidget> widget;
    if (vm) {
      vm->GetWidget(getter_AddRefs(widget));
      if (widget) {
        mWnd = widget->GetNativeData(NS_NATIVE_WINDOW);
      }
    }
  }


Just paste where your line 99 is if it's different.
Blocks: 127812
The code in question, which was

#ifdef DEBUG
  printf("\nATTENTION: New doc accessible for weak shell %x\n", mWeakShell);
#endif

was fixed in revision 1.7 of the file and later removed.

----------------------------
revision 1.7
date: 2003/05/12 22:17:20;  author: mkaply%us.ibm.com;  state: Exp;  lines: +1 -
1
OS/2 GCC debug build bustage
----------------------------
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.