PAC: Firebird can't pass through the proxy.

RESOLVED WORKSFORME

Status

()

Core
Networking
--
major
RESOLVED WORKSFORME
15 years ago
15 years ago

People

(Reporter: mirko vidovic, Assigned: Darin Fisher)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021207 Phoenix/0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021207 Phoenix/0.5

I am posting this from Phoenix 0.5 as I can't get through my company's corporate
proxy anymore using both Mozilla 1.4 and Firebird.
In ann 3 cases, I uses the same proxy.pac file.

Reproducible: Always

Steps to Reproduce:
1.you have to be at work
2.connect.
3.enter proxy credentials.


Actual Results:  
4.error : goto 3.

Expected Results:  
Like with Phoenix 0.5, it should have gotten through.

Comment 1

15 years ago
dupe of bug 205514?

Comment 2

15 years ago
did you uninstall previous releases before installing new ones ? This is
required (as mentioned in the relasee notes). See bug 205514 and its dupes.
(Reporter)

Comment 3

15 years ago
No, I assumed it was related to the files themselves so I directly put all the
new stuff in a brand new directory : I didn't install Phoenix either but just
unpacked it, so I guess it was not supposed to twiddle the registry ?
no blocker

What Do you mean with Mozilla 1.4 ? There is no 1.4, only 1.4b ..
Can you please try a nightly Mozilla build ?
(be sure that you uninstall your old Mozilla Version before you install a new
Mozilla Build)
Severity: blocker → major
(Reporter)

Comment 5

15 years ago
BTW, I don't think this is a dupe of #205514 asthis one just mentions the
proxy.pac file though I tested it by directly giving my proxy ip and port
number, like I successfully do on my Mac.
Severity: major → blocker
(Reporter)

Comment 6

15 years ago
I meant the latest stable release of Mozilla, of course.
I am afraid I can't devote much time reinstalling a new nightly build. :-/
I am approaching a deadline, here.
This is no blocker because this doesn't block Mozilla development..
There are a few bugs related to proxys fixed in the nightly builds.

It doesn't help us if you can't test a nightly and we leave this bug Unconfirmed
(waiting for the next Release) or better invalid

Severity: blocker → major

Comment 8

15 years ago
Have you tried creating a new profile?
QA Contact: benc → pacqa
Summary: Firebird can't pass through the proxy. → PAC: Firebird can't pass through the proxy.
(Reporter)

Comment 9

15 years ago
Yes, I did, or at least Firebird did this for me as it removed my existing Profile during the first 
launch.

Comment 10

15 years ago
wrong product?

Comment 11

15 years ago
This WFM on Mac Firebird, so this must be an installer problem of some kind.

Comment 12

15 years ago
I encountered this bug with Firebird 0.7, as well as with a recent
nightly build of Firebird, which I downloaded 2004-01-23. Remarkably,
the bug is not present in my old versions of Firebird and Mozilla;
there are no problems accessing the Internet from this same computer
with Firebird 0.4 (aka Phoenix 0.4) and Mozilla 1.0 (Build ID:
2002053012), which I actually use right now.

My computer runs Windows NT 4.0 (Build 1381, Service Pack 4),
and, unfortunately, sits behind a Microsoft ISA firewall.

Before unzipping Firebird 0.7 into a new empty directory, just to
err on the side of caution, I deleted the old profile of Firebird 0.4,
and after unzipping and starting Firebird 0.7 for the first time
(using the -p switch), I made sure to have the same values for 'manual
proxy configuration' as in Mozilla 1.0 (basically same procedure for
the subsequent installation of the nightly build of Firebird).

With both Firebirds, 0.7 and nightly build, the proxy authentication
window pops up correctly. However, upon entering the required data
and hitting <Return>, the window just keeps reappearing, thus blocking
Internet access. I also noticed that, from time to time, after entering
data into the first field (User Name) and pressing <Tab> to get to the
next field (Password), data cannot be entered until after I move the
mouse cursor to that field. When I finally close the authentication
window, an error message of the ISA server comes into sight, stating
'HTTP 407 Proxy Authentication required'. Come to think of it, this
looks the same as if I accidentally sent incomplete data via the
authentication window of Mozilla 1.0 or Firebird 0.4, e.g. forgetting
to enter the password and only giving the user name. So, maybe its
just the fault of that new dialogue window, and hopefully, by looking
in that direction, the bug might be spotted relatively easy ...

Anyway, please classify the bug as 'confirmed'.

Comment 13

15 years ago
I came across a simple solution to the problem of proxy authentication
not working any more because of using a newer version of Firebird
or Mozilla:

In the authentication dialogue box of newer versions, the username
has to be specified as 'domain\user' (with a backslash), instead of
'domain/user', which seems to be no longer acceptable.

Works for me, and I hope it will also work for others, especially
for you, mirko.

Comment 14

15 years ago
So is this issue resolved? Please reopen if it is not.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.