Filter after Fact action Label on POP account doesn't apply the label right away.

VERIFIED WORKSFORME

Status

VERIFIED WORKSFORME
16 years ago
10 years ago

People

(Reporter: esther, Assigned: sspitzer)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Using trunk build 20030523 on winxp, macosx and linux Filter after the fact with
Label as an action has a delay when labeling in a POP account.  Resizing pane,
clicking on a message or changing folders will trigger the action.  

1. Launch app open and log into a POP account.
2. Create a filter that matches a message in that POP account and set the action
to Label. Close the filter dialog.
3. Use the menu option to Run Filters on Folder.  

Result: the message that should have the label applied does not change colors.
Resize the 3-pane window, or click on a message or change folders and come back
to see the label applied.

Expected: the message/s to display the label color as soon as you use click on
the menu item.  IMAP does this instantly.

Comment 1

15 years ago
I'm not sure when this might have changed.  I have definitely seen this bug 
before -- and I see it in 1.6 -- but in this build:
  Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a) Gecko/20040422

running the filter after the fact causes the newly-labelled messages to update 
in the thread pane immediately.

Comment 2

15 years ago
It didn't work at all, iirc - I think I fixed this.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME

Updated

15 years ago
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.